Excel- multiplication de colonnes et addition [Résolu/Fermé]

Signaler
-
 Laol -
Bonjour,

Je fais face à un problème pour une formule Excel: je veux multiplier deux plages entre elles et additionner les résultats (je sais que c'est vague).C'est l'équivalent de (B9*D19)+(B10*D20)+(B11*D21)+(B12*D22)+(B13*D23) en une formule acceptant deux plages qui sont chacune une colonne avec n lignes.

Ex.: une facture, il y a une colonne prix unitaire et une colonne quantité, colonnes composées de centaines de lignes. Pour obtenir le sous-total de cette facture dans une case, il faut multiplier le prix unitaire de chaque produit commandé par le nombre d'exemplaires de ce produit et additionner chaque multiplication entre elles. Si je commande deux fois un crayon à 1,00$ chaque et trois fois un cahier spirale à 2,00$ chaque, le sous-total affiche (2*1)+(3*2) 8,00$.

Le problèmes c'est que s'il y a beaucoup de produits ça fait beaucoup de (B1*C1)+(B2*C2)...

Mais, je ne veux pas qu'il y est une troisième colonne affichant la multiplication du prix par la quantité et alors utiliser une case pour afficher l'addition.

Je connais très mal les matrices (c'est peut-être pas la solution). Merci d'avance pour vos hypothèses.
A voir également:

2 réponses

Messages postés
53582
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
8 avril 2021
15 627
=(B9*D19)+(B10*D20)+(B11*D21)+(B12*D22)+(B13*D23)
peut aussi s'écrire
=SOMMEPROD(B9:B13;D19;D23)

http://www.commentcamarche.net/forum/affich 9461589 excel sommeprod?dernier#dernier
103
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

un million de mercis ! ça m'a fait gagner une heure de ma vie !
Messages postés
25948
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2021
5 864
Re Raymond, une toute petite correction que Bergeron à déjé du faire:
entre D19 et D23, il faut deux points, pas un point virgule
Bien amicalement
Messages postés
53582
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
8 avril 2021
15 627
Exact !
Il était minuit, et je commençais à avoir les paupières lourdes ...
cela ne fonctionne pas !
Messages postés
53582
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
8 avril 2021
15 627
Quoi ?
Parfait merci! :)