Excel recherche d'un mot dans une cellule [Résolu/Fermé]

Signaler
-
 CL -
Bonjour,


Dans excel, j'ai besoin de trouver les cellules contenant un mot précis pour pouvoir faire une condition sur les lignes concernées.
L'idée de base est : si (la cellule a1 contient le mot déchet; produit à jeter; produit encore valide)

Quelle formule puis-je utiliser ?

Merci d'avance pour votre aide
A voir également:

2 réponses

Messages postés
434
Date d'inscription
jeudi 7 février 2008
Statut
Membre
Dernière intervention
4 juin 2010
222
Si tu veux avoir "vrai" lorsqu'il y a le mot" "déchet"

=SI(ESTERREUR(CHERCHE("déchet";A1;1));"faux";"vrai")


dans ton décorticage, c'est l'erreur qui est vraie qui renvoie "vrai"

Denis
18
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Ok merci j'avais interprété le SI à l'envers
Messages postés
17009
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
7 mars 2021
10 233
Bonjour,

Quelque chose comme ça :

=SI(ESTERREUR(CHERCHE("déchet";A1));"produit encore valide";"produit à jeter")

m@rina
Messages postés
25864
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 mars 2021
5 817 > eiram
Re eiram

La cellule en B1 renvoi exactement ce que la formule demande, à savoir:
produit encore valide si la cellule A1 ne contient pas le mot déchet ce qui est tout à fait normal
produit à jeter si vous rajouter déchet à la suite du texte en A1 ce qui est aussi normal
En fait, il semble que si cette formule ne répond pas à votre demande, c'est que cette demandeest mal formulée.

Le seul défaut de cette formule s'il devait y en avoir un, c'est qu'elle affiche produit encore valide lorrsque A1 est vide.
Ce que vous pouvez éviter en la complètant comme suit:
=SI(ESTVIDE(A1);"";SI(ESTERREUR(CHERCHE("déchet";A1;1));"produit encore valide";"produit à jeter"))
Messages postés
25864
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 mars 2021
5 817 >
Messages postés
25864
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 mars 2021

Suite message précédent
Le mieux serait je crois, de nous faire un tableau manuel de quelques lignes avec des textes en plaçant manuellement dans la colonne résultat ce que vous voulez y voir apparaitre.
Dans l'attente, on reste à votre écoute
Messages postés
25864
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 mars 2021
5 817
Bonjour

http://www.cijoint.fr/cjlink.php?file=cj200811/cijdfjx8RV.xls
Regardez au fichier ci dessus si cela correspond à ce que vous voulez faire et si oui, adapter le à votre tableau.
Attention au libellé "déchet" qui doit être strictement identique dans la formule et dans les textes.
Il y a des solutions sii vous avez des problèmes avec l'écriture du mot cherché pour l'ajuster dans les textes.
Crdcmnt
Messages postés
17009
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
7 mars 2021
10 233 >
Messages postés
25864
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 mars 2021

Hello Vaucluse ;)

Juste pour ta remarque : le 1 n'est pas nécessaire. Si rien n'est spécifié, par défaut, ce sera 1 de toutes façons ! ;)

A +

m@rina
Messages postés
25864
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 mars 2021
5 817
Exact M@rina

Je suis tellement habitué à prospecter avec l'aide fonction de excel, qui demande systématiquement le N° de départ, et sachant que chez le demandeur ça ne marchait pas, je t'ai tout de suite désignée comme coupable

C'est tellement excitant de prendre en défaut les incollables de CCM!!!!!! :>)

Pourras tu jamais me pardonner?

Crdlmnt