Nagios & NSClient++

Résolu/Fermé
Meu-ku
Messages postés
105
Date d'inscription
mercredi 20 février 2008
Statut
Membre
Dernière intervention
9 mai 2012
- 17 mars 2008 à 11:24
 Siss0ko - 10 avril 2012 à 12:02
Bonjour,
J'ai un soucis, j'obtiens sur nagios ceci "NSClient - ERROR: Invalid password"
Alors que sous NSClient aucun password n'est défini.

Voici ce que j'ai placé dans mon fichier "command.cfg" de nagios.

define command{
command_name check_nt
command_line $USER1$/check_nt -H 192.168.0.53 -p 12489 -v $ARG1$ $ARG2$
}

Souhaitez vous d'autres "copié-collé" d'un fichier de configuration en particulier???

Merci d'avance, pour vos réponses, si tant est qu'il y en aie ;-)

8 réponses

Bonjour,
Je suis sur nagios pour un projet et j'ai trouvé la solution à votre problème...
Vous êtes obligé de définir un mdp dans le fichier NSC.ini à la ligne suivante:

;# USE THIS FILE
; Use the INI file as opposed to the registry if this is 0 and the use_reg in the registry is set to 1
; the registry will be used instead.
use_file=1
allowed_hosts=192.168.1.10
password="MOT DE PASSE A DEFINIR"

Ensuite j'ai configuré le fichier command.cfg (fichier par défaut dans nagios...), en ajoutant "-s "MOT DE PASSE A DEFINIR" comme ceci:


define command{
command_name check_nt
command_line $USER1$/check_nt -H 192.168.0.53 -p 12489 -v $ARG1$ $ARG2$ -s "MOT DE PASSE A DEFINIR"
}

J'espère vous avoir aidé...pensez à vérifier vos firewalls (exception sur le port 12489).

Une dernière astuce pour tester si nsclient++ répond bien aux requêtes tcp:

1: Se placer dans le dossier: cd /usr/lib/nagios/plugins/
2: Taper la commande suivante: ./check_nt -H ADRESSEIPCLIENT -v 12489 -s "MOT DE PASSE DEFINIT"

Bon courage!
7