[Perl] Traduction algo

[Fermé]
Signaler
Messages postés
11
Date d'inscription
vendredi 1 février 2008
Statut
Membre
Dernière intervention
3 mars 2008
-
Messages postés
11
Date d'inscription
vendredi 1 février 2008
Statut
Membre
Dernière intervention
3 mars 2008
-
Bonjour,
quelqu'un pourrai maider a traduire cette algo en perl svp.

Procédure RECHERCHE()
Variable bureau1,bureau2, adresse1, adresse2 :chaine

Debut
Ouvrir(netmap.txt, L)
Ouvrir(téléphone.txt, L)

{initialiser chaines vide}
bureau1 <- ""
bureau2 <- ""

{saisir bureau1, chaine vide non admise}
Tantque bureau1=""
Saisir bureau1
Fin Tantque

{lire sequentiellement le fichier netmap.txt}
{on arrête de lire les fichier si on a atteint la fin du fichier ou si bureau1=bureau2}
Tant que (non (FinFichier netmap.txt)) ou (non (bureau1=bureau2))
Lire netmap.txt -> netmap
bureau2 <- netmap.bureau
adresse1 <- netmap.adressemac
Fintantque
Fermer(netmap.txt)

Si bureau1 = bureau2 alors
debut
adresse2 <- ""
{lire sequentiellement le fichier téléphone.txt}
{on arrête de lire les fichier si on a atteint la fin du fichier ou si adresse1=adresse2}
Tant que (non (FinFichier téléphone.txt)) ou (non (adresse1=adresse2))
Lire téléphone.txt -> téléphone
adresse2 <- téléphone.adressemac
Fintantque
Fermer(téléphone.txt)
Afficher(téléphone.numtel, netmap.bureau)
fin
sinon
Afficher("Ce bureau n'existe pas")
FinSi

Fin

2 réponses

Messages postés
3245
Date d'inscription
jeudi 23 août 2007
Statut
Membre
Dernière intervention
19 mai 2013
641
JE te conseille d'éditer ton titre et d'y indiquer qu'il s'agit de Perl, ça aidera tous les "helpeurs".
Messages postés
2
Date d'inscription
lundi 3 mars 2008
Statut
Membre
Dernière intervention
3 mars 2008
1
silvout plait est ce qu'iy ades sxercice de l'algorithme
Messages postés
11
Date d'inscription
vendredi 1 février 2008
Statut
Membre
Dernière intervention
3 mars 2008

je nai pas compris votre question?