[Excel] Test de la couleur d'une cellule.

Fermé
Amaranthe - 20 nov. 2007 à 13:55
gbinforme
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
- 24 déc. 2008 à 16:23
Bonjour,

Comment puis je tester la couleur d'une cellule de ma feuille excel ?

Ex : Je voudrais savoir si la cellule D1 est en Bleu ?

Merci d'avance.

Amaranthe.

2 réponses

gbinforme
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 616
20 nov. 2007 à 22:41
bonjour

à ma connaissance ce n'est possible qu'en mettant une fonction personnalisée.

Avec l'éditeur VBA, tu insères un module et tu copies cette fonction :
Public Function couleur(sel As Range)
Application.Volatile
couleur = sel.Interior.ColorIndex
End Function


Ex : Je voudrais savoir si la cellule D1 est en Bleu ?

Pour tester le bleu tu peux alors taper une formule de ce type :
=SI(couleur(D1)=5;"oui";"non")


En espérant que cela réponde à ton souci.
8
eriiic
Messages postés
24408
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
23 juin 2022
7 089
21 nov. 2007 à 00:06
Bonsoir,

Bon à savoir le .volatile
merci pour l'exemple
eric
0
Salut,
J'ai lu avec intérêt votre réponse, et j'ai moi aussi un problème similaire.
Des nombres sur une ligne, certains sur fond bleus. Je voudrais une formule qui ne fait la somme que de ceux qui sont sur fond bleus.
ex :
a1=8
b1=5 (bleu) c1=3
d1=7 (bleu)

=somme(a1:d1) donne 23 mais ça ne me satisfait pas.
je voudrais
=sommebleu(a1:d1) qui me donne 12.

Merci de votre aide.
0