Erreur dans l'incrémentation d'une table SQL
RésoluBonjour,
J'ai une table que je n'arrive pas à incrémenter automatiquement. Pour les autres tables c'est ok ! J'ai l'erreur
ALTER TABLE `dameron` CHANGE `id` `id` INT( 11 ) NOT NULL AUTO_INCREMENT
#1075 - Incorrect table definition; there can be only one auto column and it must be defined as a key
<font face="monospace">Et je n'arrive pas à trouver d'où ça vient !!!!</font>

Merci
2 réponses
-
Contributeur Ambassadeur
bonjour,
as-tu essayé
ALTER TABLE `dameron` CHANGE `id` `id` INT( 11 ) NOT NULL AUTO_INCREMENT, add PRIMARY KEY (`id`);
-
-
-
Modérateur
bonjour
utilise ceci
https://forums.commentcamarche.net/forum/affich-37636387-php-notice-undefined-index
-
