Erreur dans l'incrémentation d'une table SQL

Résolu

Bonjour,

J'ai une table que je n'arrive pas à incrémenter automatiquement. Pour les autres tables c'est ok ! J'ai l'erreur 

ALTER TABLE `dameron` CHANGE `id` `id` INT( 11 ) NOT NULL AUTO_INCREMENT

#1075 - Incorrect table definition; there can be only one auto column and it must be defined as a key

<font face="monospace">Et je n'arrive pas à trouver d'où ça vient !!!!</font>

Merci

2 réponses

  1. Contributeur Ambassadeur

    bonjour,

    as-tu essayé

    ALTER TABLE `dameron` CHANGE `id` `id` INT( 11 ) NOT NULL AUTO_INCREMENT, add PRIMARY KEY (`id`);
    0
    1. Merci yg_be. En fait j'ai supprimé la table id et reconstruite.

      Maintenent j'ai l'erreur 

      Notice: Undefined index: id in /mnt/111/sdb/b/a/genfamille/liste_indiv.php on line 20

      Merci

      0
      1. Contributeur Ambassadeur

        Cela ressemble maintenant à un problème PHP.

        Peux-tu partager ddu texte, et pas des images.

        Il est prudent, avant d'utliser $GET['id'], de verifier si il est présent.

        0