Utiliser un résultat de formule dans un =NB.SI

Résolu/Fermé
Thomasus - 24 juin 2022 à 11:37
 Thomasus - 24 juin 2022 à 12:35
Bonjour,

Je souhaite utiliser la formule excel suivante pour compter le nombre de ligne en fonction d'un critère de recherche:


=NB.SI(B:B;"*17759*")

Qui fonctionne très bien, ça me renvoie le bon nombre attendu.

seulement quand je l'utilise de cette façon :

=NB.SI(B:B;"*&C25&*")

C25 contenant bien la valeur "17759", ça me renvoie 0...

A terme je souhaiterais même utiliser une formule a la place du C25 si possible.

Si quelqu'un a une idée des symboles chamaniques a utiliser pour que Excel comprenne que c'est la valeur de C25 qu'il faut utiliser et pas "C25" en chaine... (j'imagine que la singerie est ici, bien sur)

j'ai essayé en retirant les " " mais excel me met la cellule en rouge pointillé.



Merci à vous.


Configuration: Windows / Firefox 101.0
A voir également:

2 réponses

ccm81 Messages postés 10867 Date d'inscription lundi 18 octobre 2010 Statut Membre Dernière intervention 18 juillet 2024 2 413
24 juin 2022 à 12:15
Bonjour
As tu essayé
=NB.SI(B:B;"*" & C25 &"*")
Cdlmnt
C'est vraiment pas mal. pour le coup mon C25 contient une formule, a voir si j'arrive a remplacer mon C25 par le contenu de ma formule directement. On avance pas mal ici, merci beaucoup.
0
Ah bah c passé c résolu. merci pour ta chamanie mon frère.
0
PapyLuc51 Messages postés 4357 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 17 juillet 2024 1 425
24 juin 2022 à 12:13
Bonjour,

À tenter

=NB.SI(B:B;C25)

Cordialement
J'ai besoin des ** malheureusement.
0