SOMME avec ensemble vide

Signaler
Messages postés
24
Date d'inscription
jeudi 10 juin 2021
Statut
Membre
Dernière intervention
14 juillet 2021
-
Messages postés
26106
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021
-
Bonjour à tous,

Mon excel se sépare en 2 parties. Une où les informations sont présentes (page 1) et l'autre où je souhaite faire les calculs (page 2). Dans la page 1 j'observe des valeurs sous seuil. J'ai 3 seuils donc 1 valeur par seuil normalement mais il arrive que 1,2 ou 3 des 3 seuils n'aient pas de valeur pour une même date (le seuil 2 n'a pas de valeur pour la date donné du 1/06/2020).

Dans ma page 2 je souhaite faire la somme par date des valeurs sous seuils mais il s'avère que comme certaines valeurs valent "ensemble vide", il me marque #VALEUR.
Je pourrai dédoubler chaque colonne et remplacer la valeur "Ensemble vide" par 0. Or j'ai énormément de seuils.

J'aimerais donc savoir s'il est possible de faire cette somme en faisant comprendre à excel, qu'au moment de la somme page 2, il faut remplacer les valeurs "Ensemble vide" par 0. Je ne peux pas remplacer directement tous les ensemble vide par 0 en page 1 car je fais aussi un calcul de moyenne (pas sur cet excel) ce qui fausserait tout dans la démarche appliquée.

Merci.


Configuration: Windows / Chrome 91.0.4472.124

4 réponses

Messages postés
3238
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
20 juillet 2021
459
Bonjour,

Un fichier EXCEL (test ou non), complété par des explications exhaustives et des exemples remplis à la main, mis sur https://www.cjoint.com/ permettrait aux intervenants de répondre plus précisément à ta question. Ces mêmes intervenants ne sont pas obligés de reconstituer ton fichier.

Crdmt
Messages postés
26106
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021
5 992
Bonjour
pas tout compris mais en principe, si vous utilisez SOMME(champ) Excel ne teint pas compte des textes dans le champ et ne somme que les valeurs numérique
Quele est votre problème. Pouvez vous déposer un modèle avec quelques explications par exemple ici:
https://mon-partage.fr
et revenir coller le lien créé sur le site
à vous lire
crdlmnt
Messages postés
24
Date d'inscription
jeudi 10 juin 2021
Statut
Membre
Dernière intervention
14 juillet 2021

Bonjour,

Ma précédente réponse ne s'est pas enregistré j'en suis désolé.
Je souhaite faire la somme de B2, C2 et D2 en page 2. Or C2 = "ensemble vide". Je pourrais remplacer "ensemble vide" par 0 mais je fais aussi une moyennes avec ces valeurs, et cette moyenne ne prend que les cases aillant des valeurs donc si je mets 0, cela fausse tout.

En espérant vous avoir aidé.

https://mon-partage.fr/f/vOs9PuB6/
Messages postés
26106
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021
5 992
Binjour
comme expliqué précédemment et si votre champs à sommer est bien continu, écrivez:
=SOMME('Page 1'!B2:D2)
plutôt que la ligne de somme, et les textes ne sont pas pris en compte
revenez par contre si vous avez des cellules non consécutives à sommer
crdlmnt