Formule Si

Résolu/Fermé
mayou478
Messages postés
44
Date d'inscription
jeudi 9 juillet 2020
Statut
Membre
Dernière intervention
28 avril 2022
- 3 juil. 2021 à 17:54
mayou478
Messages postés
44
Date d'inscription
jeudi 9 juillet 2020
Statut
Membre
Dernière intervention
28 avril 2022
- 3 juil. 2021 à 21:45


Bonjour,

je cherche désespérément une formule à mettre en mise en forme conditionnelle mais cela ne marche pas ....

je m'explique:
Dans les zone D, E, F il y a des nom ...
Dans les zone G, H, I, J, K, L il y a rien ou (repos)

je veux en gros si dans les zone D, E, F il y a rien alors les autre zone avec un point (.) sinon rien

pourriez vous m'aider s'il vous plait
voir photo ci joint

8 réponses

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 265
Modifié le 3 juil. 2021 à 18:06
Bonjour
la mise en forme conditionnelle ne vous mettra pas de point. Vous pouvez seulement jouer sur les formats
si vous voulez afficher un point il faudra:
  • soit passer par une formule dans les cellules
  • soit garnir au départ toutes les cellules d'un point et lui donner la même couleur que la cellule. La MFC fera apparaître le point en changeant la couleur de police.


crdlmnt

0
mayou478
Messages postés
44
Date d'inscription
jeudi 9 juillet 2020
Statut
Membre
Dernière intervention
28 avril 2022

3 juil. 2021 à 18:13
bonjour,
j'ai besoin que la cellule note un point ou autre automatiquement

voici ma formule:

=SI(ESTVIDE($C$9:$E$78);($F$9:$K$78);".";"")

après je peut remplacer le point par autre chose je veut un lettre, un mot, ou un symbole ...
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 265
3 juil. 2021 à 18:36
Alors il faut traiter ligne par ligne avec NB.SI (exemple sur ligne 9):
=SI(NB.SI($C9:$E9;"")=3;".";"")
en ne bloquant pas le N° de ligne pour tirer la formule sur le tableau
crdlmnt
0
mayou478
Messages postés
44
Date d'inscription
jeudi 9 juillet 2020
Statut
Membre
Dernière intervention
28 avril 2022

3 juil. 2021 à 18:41
J'ai pas compris…
Cette formule je la mets dans quoi ?
mise en forme conditionnelle ? Ou dans une cellule ?
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
mayou478
Messages postés
44
Date d'inscription
jeudi 9 juillet 2020
Statut
Membre
Dernière intervention
28 avril 2022

3 juil. 2021 à 18:44
Si c'est dans une cellule ça ne va pas non plus car il y a des gens qui rentre et qui sortent régulièrement je ne veux pas m'amuser à retirer la formule et à m'emmêler les pinceaux

La mise en forme conditionnelle me permettrait de faire des choses automatiques je supprime le nom donc ma ligne affiche un point. une lettre ou autre

Ou peut-être que ma formule n'est pas bonne et que je ne réfléchis pas correctement…
Peut-être je dois trouver ma formule autrement ?
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 265
Modifié le 3 juil. 2021 à 19:30
Comme déjà écrit, vous ne pouvez pas mettre un point avec une mise en forme conditionnelle qui n'agit que sur les formats pas sur les contenus, et si vous ne voulez pas de formule dans les cellules, vous n'avez que la solution du "masque" par le formatage couler fond/couleur police.
Relisez mon premier message
Par contre vous pouvez changer la couleur de cellule avec la formule dans la MFC:
=NB.SI($C9:$E9;"")=3
dans la fenêtre de MFC, en sélectionnant le champ et en adressant la formule à la première ligne du champ sélectionné, et en respectant bien les $
crdlmnt

0
via55
Messages postés
13797
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
5 août 2022
2 467
3 juil. 2021 à 21:16
Bonsoir

Comme te l'a bien expliqué mon ami Vaucluse que je salue au passage ☺, tu ne peux pas faire inscrire une valeur dans une cellule par MFC mais avec la formule de MFC qu'il t’indique tu peux modifier le remplissage de la cellule et la remplir avec un motif choisi parmi ceux proposés par Excel, des points par exemple :
https://www.cjoint.com/c/KGdtmkSdb4r

Cdlmnt
Via
0
mayou478
Messages postés
44
Date d'inscription
jeudi 9 juillet 2020
Statut
Membre
Dernière intervention
28 avril 2022

3 juil. 2021 à 21:45
Bon, merci à vous deux ! :)
je vais regarder ça ...

merci pour votre patience, :)
cordialement.
0