Formule "SI...." [Résolu]

Signaler
-
 Lo -
Bonjour à tous,

Je suis bloquée sur la formule "SI alors" dans mon tableau.
Il s'agit d'un fichier pour transférer des points d'une équipe vers une autre
Feuille 1:
Colonne A --> le nom de l'équipe qui donne les points ( liste menu déroulant)
Colonne B --> le nom de l'équipe qui reçoit les points ( liste menu déroulant)
Colonne C --> le nombre de points.
Feuille 2:
Colonne A --> le nom d'une équipe ( pas de menu déroulant)
Colonne B --> les points en plus
Colonne C --> les points en moins.

En fonction de ce qu'on va mettre en feuille 1 , j'aimerais que les points se mettent automatiquement sur la feuille 2 ( en plus ou en moins) en fonction de l'équipe envoie et de l'équipe qui reçoit de la feuille 1.
Je pensais utiliser la formule SI...alors "les points" et si faux "0"

J'espère avoir été claire :(
Un grand merci d'avance pour votre aide

3 réponses

Bonsoir,

Ce viens d'essayer mais ça ne fonctionne pas :(
Serait-possible que ce soit à cause du fait que dans les colonnes A et B , on choisit l'info au départ du menu déroulant?
Merci pour votre aide
Messages postés
2477
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
12 juin 2021
1 133
Bonjour
Un exemple de classeur serait à mettre sur Cjoint pour avoir les meilleures réponses possibles.
Comment déposer sur Cjoint.fr
>
Messages postés
2477
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
12 juin 2021

https://www.cjoint.com/c/KEfsfCNA8wj

Voici si j'ai bien suivi la procédure.

l'idée est d'automatiser la feuille "vue corrigée" en fonction des données mises dans la feuille transfert
Encore merci pour votre temps
En fait cela fonctionne si je mets dans ma feuille 2 cette formule

SI=(A1='F1'!A1;'F1'!B1;0)

mais comment faire pour reporter la formule sur les autres cellules ( j'ai 25 lignes en feuille 1 )
J'ai essayé ceci pour tirer la formule mais ça ne fonctionne pas

SI=(A1='F1'!A$1:A$25;'F1'!B$1:B$25;0) et aussi ceci SI=(A1='F1'!$A$1:$A$25;'F1'!$B$1:$B$25;0)
Messages postés
2477
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
12 juin 2021
1 133 > Lo
Bonjour
feuille "Vue corrigée"
en B4
=SOMMEPROD((Transfert!$C$3:$C$25=A4)*(Transfert!$D$3:$D$25))

En C4
=SOMMEPROD((Transfert!$B$3:$B$25=A4)*(Transfert!$D$3:$D$25))

A recopier vers le bas
>
Messages postés
2477
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
12 juin 2021

Magnifique :)
Big Merci
Cela fonctionne
Je vous souhaite une agréable journée
Messages postés
615
Date d'inscription
mercredi 5 octobre 2016
Statut
Membre
Dernière intervention
25 mai 2021
51
Bonjour,
je pense que la fonction SOMME.SI.ENS devrait faire l'affaire
Bonsoir,

je ne maitrise pas très bien cette formule, mais après avoir essayé j'ai dans ma cellule le message "#EPARS!" :(
Messages postés
615
Date d'inscription
mercredi 5 octobre 2016
Statut
Membre
Dernière intervention
25 mai 2021
51 > Lo
Vous devez avoir des cellules fusionnées et votre formule contient très certainement un champ C3:C4 ou qqchose dans le genre à modifier en supprimant le : et la cellule qui suit
Messages postés
2477
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
12 juin 2021
1 133
Bonsoir
si bien compris une piste