Comment calculer la somme de plusieurs champs avec un champ vide

Signaler
-
 Sylla.junior2 -
bonjour
jai une table nommee " notes" contenant plusieurs champs ( anglais, maths , svt, physique......) . l'eleve n'a pas eu de note en svt donc vide. quand je fais mon calcul en utilisant " generateur expression" je remarque que si ya un vide le calcul ne marche pas .
voila l'epression que jai utilisée :
=([anglais]*1+[maths)]*1+[svt]*1+[physique]*1) . mon probleme comment le calcul peut marcher avec une matiere sans note ?

1 réponse

Messages postés
15302
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
25 avril 2021
837
bonjour,
moi j'essaierais:
=nz(anglais)+nz(maths)+nz(svt)+nz(physique)
Messages postés
15302
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
25 avril 2021
837 > Sylla.junior2
as-tu essayé ma suggestion?
>
Messages postés
15302
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
25 avril 2021

Oui monsieur yg_be mais je sais pas pourquoi ça me met toujours message derreur: vous aviez entré un indicateur ou tapé des parenthèses apres la constance null
Messages postés
15302
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
25 avril 2021
837 > Sylla.junior2
il me semble que tu n'as pas essayé ma suggestion, tu l'as totalement modifiée.
>
Messages postés
15302
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
25 avril 2021

Ok monsieur je vais carrément reprendre et je vous fais le retour

je comprends pas pourquoi ca passe passe et toujours un message apparait: " vous aviez entré un indicateur non valide ou tapé des parenthèses apres la constance non nul. voila l'expression que jai utilisée :
=(nz[anglais] + nz[ anglais (oral) ] + nz[all/espagnol] + nz[eps] + nz[edhc] + nz[histoire_geo] + nz[physique_chimie] + nz[svt] + nz[orthographe] + nz[compo_franc] + nz[maths] + nz[dessin/musiq] )