Chiffre si cellule contient tel ou tel texte [Résolu]

Signaler
-
 antoine -
Bonjour,

Sur google sheet, je cherche à faire apparaître des chiffres (1 - 5) dans une cellule B1 si A1 contient un certain mot.

--> Si A1 contient "rarement" alors B1 = 1
Si A1 contient "utilise" alors B1 = 2
Si A1 contient "combine" alors B1 = 3
Si A1 contient "sélectionne" alors B1 = 4
Si A1 contient "réfléchis" alors B1 = 5.

Quelle est la formule à utiliser pour ce cas ?
Merci d'avance pour votre aide !

5 réponses

Messages postés
3291
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
21 juin 2021
933
Alors s'il n'y a que ces 5 mots à chercher cette formule

=SI(A1<>"";SI(NB.SI(A1;"*rarement*")>0;1;SI(NB.SI(A1;"*utilise*")>0;2;SI(NB.SI(A1;"*combine*")>0;3;SI(NB.SI(A1;"*sélectionne*")>0;4;SI(NB.SI(A1;"*réfléchis*")>0;5;"")))));"")


S'il y a plus de mots à chercher ajouter des SI(NB.SI) après 5; et avant ""))))) et ne pas oublier à la suite de fermer autant de ) qu'il y a de si ajoutés

Cordialement
Messages postés
3291
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
21 juin 2021
933
Bonjour,

Si le mot est unique dans la cellule A1 - un petit tableau hors cadre et une recherchev

https://www.cjoint.com/c/KDmluxG7DlB

Cordialement

Bonjour,

Merci pour votre réponse. Le mot est contenu dans un texte.

Cordialement

Wow ça a marché !! Merci beaucoup !!

Bonne journée à vous !
allo tu peux me doner 100000000 de vebux et de robux svp