Séquencement automatisé avec plus d'une condition [Résolu]

Signaler
Messages postés
26
Date d'inscription
mardi 14 avril 2020
Statut
Membre
Dernière intervention
7 mai 2021
-
Messages postés
26
Date d'inscription
mardi 14 avril 2020
Statut
Membre
Dernière intervention
7 mai 2021
-
Bonjour,

Je tente d'automatiser le séquencement généré à partir de 2 conditions. En fait, j'ai réussi à le faire avec une seule condition sur "Le type" (colonne A de la feuille "Requirements Register"; "Functional" et "Non-Fonctional"). Donc, le séquencement sera généré automatiquement pour tous les types "Functional" et les types "Non-Functional". Le hic est que je dois aussi considérer s'il s'agit du préfix "PI" ou "SAO" en plus de considérer s'il s'agit de Functional" et "Non-Functional". Donc, le résultat devra être:

Si Functional et PI, alors F.PI.01, F.PI.02, etc.
Si Non-Functional et PI, alors NF.PI.01, NF.PI.02
Même chose pour "SAO".
Si Functional et SAO, alors F.SAO.01, F.SAO.02, etc.
Si Non-Functional et SAO, alors NF.SAO.01, NF.SAO.02

Se référer au chiffrier déposé sur https://www.cjoint.com/c/KCdtleqt2OV

Par avance, merci de votre temps :-)

Slts,

Stephan

Configuration: Windows / Edge 88.0.705.81

2 réponses

Messages postés
13029
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
15 juin 2021
2 201
Bonsoir Stephan

Si j'ai bien compris ce que tu recherches, formule en B4 :
=SI(G4<>"";[@[F/NF]]&"."&D4&"."&TEXTE(NB.SI.ENS($C$4:C4;C4;$D$4:D4;D4);"00");"")

De plus pas besoin d'une formule avec SI en C4, celle-ci suffit :
=GAUCHE(A4;1)

Cdlmnt
Via
Messages postés
26
Date d'inscription
mardi 14 avril 2020
Statut
Membre
Dernière intervention
7 mai 2021

Super! C'est "functional" ;-)

Merci Via