Condition sur une cellule n'ayant qu'un texte

Fermé
JPT - 26 janv. 2021 à 11:06
 JPT - 28 janv. 2021 à 19:00
Bonjour et merci pour votre aide,

J'ai une cellule (C1) qui ne contient que du texte, par exemple: "il fait soleil aujourd'hui"

Je voudrais, dans une autre cellule (C2) écrire "attention au coup de soleil" si la cellule (C1) contient le mot "soleil" ou "il pleut" si la cellule (C1) ne contient pas le mot "soleil"

Je tourne en rond

6 réponses

PapyLuc51
Messages postés
3735
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
26 septembre 2022
1 168
26 janv. 2021 à 21:20
Bonsoir,

S'il n'y a que ces 4 possibilités, cette imbrication de si()

=SI(C1="CELIBATAIRE";"célibataire";SI(NB.SI(C1;"*EPOUX*")=1;"Marié";SI(NB.SI(C1;"*VEUF*")=1;"Veuf";SI(NB.SI(C1;"*DIVORCE*")=1;"Divorsé";"non précisé"))))

Cordialement
1
PapyLuc51
Messages postés
3735
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
26 septembre 2022
1 168
27 janv. 2021 à 18:09
Bonsoir,
Si cette réponse a résolu ton problème, clique sur le bouton vert "Marquer comme résolu"

Cordialement
0
Merci beaucoup pour votre aide. J’apprécie énormément votre savoir.
0
pijaku
Messages postés
12259
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
9 août 2022
2 703
26 janv. 2021 à 11:16
Bonjour,

Essayez ceci :
=SI(NON(ESTERREUR(TROUVE("soleil";C1)));"attention aux coups de soleil";"il pleut")

0
DjiDji59430
Messages postés
3647
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
25 septembre 2022
554
26 janv. 2021 à 11:18
Bonjour à tous,

Un exemple :

https://www.cjoint.com/c/KAAksm4Tboa

Crdlmt
0
PapyLuc51
Messages postés
3735
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
26 septembre 2022
1 168
26 janv. 2021 à 11:23
Bonjour,

Une autre

=SI(NB.SI(C1;"*soleil*")=1;"attention au coup de soleil";"il pleut")

Cordialement
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Bonjour et merci pour cette réponse rapide et efficace. Elle fonctionne mais j'aimerais l'étoffer par exemple:
En fait, je fais des recherches sur des disparitions de marins pendant les grandes pêches en Islande fin 19ème et début 20ème siècles.
Toujours dans la cellule (C1), j'ai la possibilité d'avoir plusieurs textes. ces textes sont:
EPOUX DE xxxxx
VEUF DE xxxxx
CELIBATAIRE
DIVORCE DE xxxxx
Cellule vide
Dans la cellule (C2) je voudrais pouvoir remplacer "EPOUX DE xxx" par "Marié", "VEUF DE xxxx" par "Veuf", "CELIBATAIRE" par "Célibataire", "DIVORCE DE xxx" par "Divorcé" et " " par "Non précisé" et tout ça en 1 seule formule.
Cordialement
0
DjiDji59430
Messages postés
3647
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
25 septembre 2022
554
26 janv. 2021 à 11:53
Bonjour,

Un fichier EXCEL (test ou non), complété par des explications exhaustives et des exemples remplis à la main, mis sur https://www.cjoint.com/ permettrait aux intervenants de répondre plus précisément à ta question. Et donne aussi ta version d'Excel, si ce n'est déjà fait.

Crdmt
0