Incrémentation auto pour chaque nouveau client [Résolu]

Signaler
-
 patriceFT -
Bonjour à tous,

Dans ma feuille, en colonne A, j'ai les références numériques (1, 2, 3 etc), dans la colonne B, le nom du client, dans la C le prénom etc. Je voudrais qu'a chaque enregistrement d'un nouveau client la référence s'affiche automatiquement dans la ligne de la colonne A.
J'avais pensé écrire la formule suivante :
= Si (B3 <> ""; A2+1, "")
mais cela ne marche pas :(
merci pour votre aide



Configuration: Windows / Chrome 87.0.4280.88

4 réponses

Messages postés
3007
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
18 janvier 2021
836
Bonjour,

Remplacer la virgule par un point-virgule et supprimer les espaces

=Si(B3<>"";A2+1;"")


Cordialement
Merci PapyLuc51,

Je n'ai plus de message d'erreur après avoir modifié mon scripte comme vous me l'avez conseillé.
Mais la référence ne s'affiche pas automatiquement lors d'un nouvel enregistrement de client. En fait, aucun N° d'apparait dans la colonne A quand je remplis la colonne B et les suivantes.

Bonnes fêtes de fin d'années
Messages postés
3007
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
18 janvier 2021
836
Bonjour patriceFT,

En A2 mettre la première formule =SI(B2<>"";1;"")
En A3 la formule corrigée
maintenir le clic sur le petit carré en bas à droite de la cellule A3 et faire descendre jusqu'à la dernière cellule ou si le tableau est déjà constitué faire un double clic sur ce même carré.

Sinon, sans visu pour comprendre, impossible de répondre ; alors un petit fichier test (avec quelques exemples et les résultats attendus) sera le bienvenu.

Aller dans https://www.cjoint.com/
Cliquer sur "PARCOURIR" pour sélectionner le classeur ou "FAIRE UN GLISSER DEPOSER" dans la fenêtre ;
Clic sur le bouton "CREER LE LIEN" ;
"CLIC DROIT" sur le lien créé "COPIER L'ADRESSE DU LIEN" ;
Sur le post Clic droit "COLLER".

ou dans https://mon-partage.fr/

Cordialement
Bonjour PayLuc51,

Formidable ! C'est exactement ce que je cherchais depuis plus d'une semaine. Mes cellules s'incrémentent automatiquement dés l'entrée du nom d'un nouveau client.

Encore merci ainsi qu'aux webmasters qui nous mettent à disposition ce forum.

Bonne fin d'année