Clavier mort en sortie de veille

Signaler
Messages postés
57
Date d'inscription
mercredi 3 novembre 2010
Statut
Membre
Dernière intervention
8 janvier 2021
-
Messages postés
57
Date d'inscription
mercredi 3 novembre 2010
Statut
Membre
Dernière intervention
8 janvier 2021
-
Bonjour, avec un ordi sony vaio le pb se pose depuis ubuntu 16.04,a la reprise le clavier ne réponds pas ,la ruse etait de changer d utilisateur ce qui relancait le clavier,...je passe à ubuntu 20.4 puisque le 16.04 arrive à sa fin ,et là plus moyen de réactiver le clavier ,ce qui est embétant le mode veille étant bien pratique.Quelqu un aurait il une idée.Merci




Configuration: Linux / Firefox 83.0

11 réponses

Messages postés
29493
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
8 janvier 2021
7 009
C'est effectivement une bonne approche, moins il y a d'option, plus la configuration sera standard et plus on pourra espérer que ça marche normalement. Maintenant que tu connais la procédure il faut déterminer la bonne combinaison d'options.

Il n'est pas exclu qu'il faille à terme ton jeu d'option minimal ne marche pas mieux, mais ce sera toujours ça de pris. Ensuite il faudra continuer à farfouiller sur le net à la recherche d'autres options de ce genre (il suffit de chercher dans google les options retenues, ton modèle de pc, etc... et voir ce que les gens racontent).

Bon courage, c'est un peu pénible, mais je sens que tu n'es plus très loin.
Messages postés
29493
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
8 janvier 2021
7 009
Bonjour,

Est-ce que des raccourcis clavier tel que ctrl alt backspace, ctrl alt suppr, ctrl alt f1 fonctionnent ? Si ça n'est pas le cas, c'est peut être "plus grave" que juste le clavier (kernel panic ou autre). Il serait intéressant de regarder dans les logs si quelque chose est écrit aux heures des hibernations ou sorties d'hibernations (e.g.
sudo gedit /var/log/messages
).

Bonne chance
Messages postés
57
Date d'inscription
mercredi 3 novembre 2010
Statut
Membre
Dernière intervention
8 janvier 2021

Bonjour et merci pour la réponse.
Au premier ecran de sortie de veille (demande de mot de passe) aucun raccourci ne fonctionne seule la souris marche.Avec ubuntu 16.04 je pouvais faire: changer d utilisateur ce qui réactivait le clavier,avec ubuntu 20.04 pas possible ,je suis donc obligé d arrêter l ordi (à la sauvage)
Messages postés
29493
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
8 janvier 2021
7 009
Bonjour,

Si la souris marche c'est une information importante, ça veut dire que ça n'est pas un kernel panic mais comme tu le disais un problème entre ton clavier et l'hibernation.

Tu peux essayer de faire ce qui est indiqué cette discussion. Pense également à préciser le modèle de ton ordinateur dans ton prochain message.

Bonne chance
Messages postés
57
Date d'inscription
mercredi 3 novembre 2010
Statut
Membre
Dernière intervention
8 janvier 2021

Bonjour.
L’ordi est un Sony vaio SVE1513B1EW.J ai fait la manip sur les deux installations que j ai( Ubuntu 16.04 et 20.04) hélas sans résultat.Je crois que c est lié à ces ordinateurs,..
Messages postés
29493
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
8 janvier 2021
7 009
Bonjour

A) Donc concrètement tu as bien fait tout ce qui était indiqué dans cette discussion, à savoir corriger
/etc/default/grub
(via
sudo gedit /etc/default/grub
) de sorte à ce que
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash atkbd.reset" 
+ lancer
sudo update-grub
?

B) De plus, je viens de tomber sur cette discussion et vu que c'est un kernel récent dont il est question (donc, probablement le même que tien, à contrôler avec
uname -r
), ça pourrait mieux marcher : Solution was to load the module `atkbd` with the option `reset=1`.

1) Si le module en question est chargé (voir
lsmod | grep atkbd
), décharge-le avec la commande :

sudo rmmod atkbd


2) Ensuite, charge le module avec l'option indiquée

sudo modprobe atkbd reset=1


3) Puis passe en hibernation, et regarde si le clavier fonctionne désormais correctement.

4) Seulement si ça a marché, tu peux comme expliqué ici créer un fichier pour charger ce module au démarrage avec la bonne option.

sudo gedit /etc/modprobe.d/atkbd.conf &


Dans ce fichier, écris :

options atkbd reset=1


Enfin crée
/etc/modules-load.d/atkbd.conf
:

sudo gedit /etc/modules-load.d/atkbd.conf &


Dans ce fichier, écris :

atkbd


Vérifie que le module est bien chargé automatiquement au redémarrage suivant (
sudo reboot
, puis
lsmod
). Si c'est le cas, vérifie que la sortie d'hibernation continue à bien fonctionner.

Bonne chance
Messages postés
57
Date d'inscription
mercredi 3 novembre 2010
Statut
Membre
Dernière intervention
8 janvier 2021

Bonjour
A je pense avoir fait correctement ce qui etait indiqué et quand je vais dans le dossier /etc/default/grub je trouve bien :GRUB_CMDLINE_LINUX_DEFAULT="quiet splash atkbd.reset"

B voici ce que me renvoient les commandes

philippe@philippe-SVE1513B1EW:~$ uname -r
5.4.0-58-generic
philippe@philippe-SVE1513B1EW:~$ lsmod | grep atkbd
philippe@philippe-SVE1513B1EW:~$ sudo rmmod atkbd
[sudo] Mot de passe de philippe :
rmmod: ERROR: Module atkbd is builtin.
philippe@philippe-SVE1513B1EW:~$ sudo modprobe atkbd reset=1
philippe@philippe-SVE1513B1EW:~$
philippe@philippe-SVE1513B1EW:~$
philippe@philippe-SVE1513B1EW:~$

et le clavier reste inerte
Merci pour ton aide
Messages postés
29493
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
8 janvier 2021
7 009
Pardon pour la réponse tardive, mais c'étaient les vacances :-)

Malheureusement, le pilote de ton clavier est intégré dans le noyau et non compilé en tant que module d'après l'erreur renvoyée par
rmmod
, ce qui signifie que tout ce que j'ai expliqué en (B) dans mon message précédent ne s'applique pas dans ton cas. Je suspecte que passer la bonne option au noyau via grub comme expliqué en (A) est la bonne manière de faire, mais il faut trouver la bonne option/syntaxe.

Corrige
/etc/default/grub
, par exemple avec la commande
sudo gedit /etc/default/grub
de sorte à avoir :

GRUB_CMDLINE_LINUX="quiet splash atkbd.reset=1"



Sauve, quitte, puis lance
sudo update-grub
. Avant de redémarrer assure toi que l'option est bien répercutée en contrôlant le résultat de :

grep quiet /boot/grub/grub.cfg


Ensuite croisons les doigts pour que ça résolve le problème.

Si ça ne marche toujours pas, sur ce lien ils proposent une variation encore plus "compliquée" que tu peux tester au cas où :

GRUB_CMDLINE_LINUX="atkbd.reset=1 i8042.nomux=1 i8042.reset=1 i8042.nopnp=1 i8042.dumbkbd=1"


(répète le procédure complète).

Bonne chance
Messages postés
57
Date d'inscription
mercredi 3 novembre 2010
Statut
Membre
Dernière intervention
8 janvier 2021

Bonjour et bonne année .Il semble que la dernière proposition fonctionne!!!
petit bémol les voyants maj et pavé num ne marchent plus et le démarrage se fait en mode rescue.
Penses tu que je peux modifier la ligne en supprimant élément par élément pour voir le quel redémarre le clavier?
Merci pour le temps passé j espère que les vacances étaient bonnes.....
Messages postés
57
Date d'inscription
mercredi 3 novembre 2010
Statut
Membre
Dernière intervention
8 janvier 2021

Hélas !
j ai supprimé la derniere option et ça ne marchait pas je l ai donc remise mais maintenant je n arrive plus à mettre grub a jour,quand je tappe sudo update-grub j ai la réponse :
[sudo] Mot de passe de philippe :
Sourcing file `/etc/default/grub'
/usr/sbin/grub-mkconfig: 26: /etc/default/grub: want: not found
Messages postés
57
Date d'inscription
mercredi 3 novembre 2010
Statut
Membre
Dernière intervention
8 janvier 2021

j ai remis une copie de grub que j avais et cela remarche.. je vais essayer d enlever les options...