Plage changeante [Résolu]

Signaler
Messages postés
2
Date d'inscription
vendredi 4 décembre 2020
Statut
Membre
Dernière intervention
7 décembre 2020
-
Messages postés
2
Date d'inscription
vendredi 4 décembre 2020
Statut
Membre
Dernière intervention
7 décembre 2020
-
Bonjour,

J'ignore si cette question vous a deja ete posé mais j'ai une formule si dessous

=ROUNDDOWN($BI$8-COUNTIF(C2:BC2;"X");0)

Ou la colonne "BC2" change selon la semaine de de l'année que donne Windows, mais j'aimerais que la cellule "C2" change selon la dernière cellule non vide soit quelques chose comme ca :

"(La dernière "X"; BC2)"

pouvez vous m'aider dans ce problème s'il vous plait ?







Configuration: Windows / Chrome 87.0.4280.88

3 réponses

Messages postés
53111
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 janvier 2021
15 082
Bonjour.

Quelle est ta version d'Excel ?
En effet ta formule est en anglais !
Messages postés
2962
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
18 janvier 2021
411
Bonjour à tous,

Et on doit retrouver quoi ? 40 ?

Crdlmt
Messages postés
25751
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 janvier 2021
5 715
Bonjour
essayez avec cette formule matricielle à entrer avec le touche enter en maintenant les touches ctrl et shift enfoncées
(elle doit s'afficher automatiquement entre accolades dans la barre de formule)

=SIERREUR(INDEX($AA$1:$BC$1;MAX(SI($AA2:$BC2="X";COLONNE($AA:$BC)))-26);"")

la correction de -26 est nécessaire pour que le numéro dans la feuille de la première colonne du champ (ici, donc 27)renvoie 1

crdlmnt
ps
j'ai pris les infos sur l'image, pour adapter au départ en C

=SIERREUR(INDEX($C$1:$BC$1;MAX(SI($C2:$BC2="X";COLONNE($C:$BC)))-2);"")

et aussi, toujours en matricielle
=MAX(SI($C2:$BC2="X";COLONNE($C:$BC)))
renvoie le N° de colonne dans la feuille

Messages postés
2
Date d'inscription
vendredi 4 décembre 2020
Statut
Membre
Dernière intervention
7 décembre 2020

Merci, vous m'avait bien aider pour fait mon tableau Excel.