Incrémentation d'indexage, sur-indexage. [Résolu]

Signaler
Messages postés
9
Date d'inscription
jeudi 22 octobre 2020
Statut
Membre
Dernière intervention
23 novembre 2020
-
Messages postés
25592
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 novembre 2020
-
Bonjour,

Après multiples recherches, je ne trouve pas mon bonheur, je vous pose donc la question:

J'ai en colonne D des références (AAA1; AAA2; AAA3;...), en colonne E un numéro d'indexage (1; 2; 3;...) et en colonne F un sur-indexage si dans la colonne E j'ai des doublons 1_2; 1_3 ou 4_2; 4_3; 4_4..)

Mais s'il y a plusieurs doublons, il faudrait incrémenter en fonction des précédents doublons:
en colonne E: 1_ 1; 1_2; 1_3 s'il y a 3 même index "1"
ou
4_1; 4_2 s'il y a 2 index "4"
Etc.

Voilà j'espère avoir été clair.

Merci d'avance de votre aide!!

Sully

6 réponses

Messages postés
25592
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 novembre 2020
5 614
Bonjour
avec cette formule en F2, est ce ça que vous cherchez?
revenez si ça ne convient pas
=D2&"_"&NB.SI($D$2:D2;D2)
attention au blocage sur le premier D2, pas sur les autres dans le NB.SI
crdlmnt
Messages postés
9
Date d'inscription
jeudi 22 octobre 2020
Statut
Membre
Dernière intervention
23 novembre 2020
1
Bonjour,

Merci pour votre aide,

Cependant en l'appliquant sur mon fichier, cela ne me donne pas ce que je recherche.
Je joins mon fichier pour être plus clair.

https://mon-partage.fr/f/yZht4WCt/

Merci d'avance

Sully
Messages postés
25592
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 novembre 2020
5 614
bonjour
le fichier, c'est OK mais on ne voit pas le raisonnement pour appliquer ce que vous attendez, don ne voit même pas ce que vous attendez
vous pouvez préciser les règles et l'affichage attendu en E et F surtout en F13/14/15 et F10 avec trois fois 4_5? parce que là c'est le brouillard complet, du moins pour moi
à vous lire
crdlmnt
Messages postés
9
Date d'inscription
jeudi 22 octobre 2020
Statut
Membre
Dernière intervention
23 novembre 2020
1
Mince désolé,

En fait, Si un indexage colonne E à des doublons ou plus (ex: les "4" en colonne E), je souhaiterais que des indexages "4_1; 4_2; 4_3; 4_4" apparaissent en face dans la colonne F et que cela se suivent si jamais je rajoute encore des lignes et encore des "4" en colonne E.
Messages postés
9
Date d'inscription
jeudi 22 octobre 2020
Statut
Membre
Dernière intervention
23 novembre 2020
1
En colonne E se sont des données rentrées manuellement
Messages postés
25592
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 novembre 2020
5 614
ça n'explique toujours pas pourquoi vous avez plusieurs fois des valeurs identiques en F?
tout ce que je peux vous proposer avec ces infos:
en F6 à tirer vers le bas:
=SI(E6="";"";E6&"_"&NB.SI($E$6:E6;E6)))

et si vous ne voulez pas voir de valeur en F lorsqu'il n'y a qu'un exemplaire du code en E (comme le 3 par exemple):
=SI(OU(E6="";NB.SI(E:E;E6)=1);"";E6&"_"&NB.SI($E$6:E6;E6))

et pour faire complet si vous voulez que le surcodage du 2° commence à 1:
=SI(OU(E6="";NB.SI(E:E;E6)=1);"";E6&"_"&NB.SI($E$6:E6;E6)-1)

.......peux pas faire mieux!
Messages postés
9
Date d'inscription
jeudi 22 octobre 2020
Statut
Membre
Dernière intervention
23 novembre 2020
1
Oh ouiiiii Tooop!!

Désolé pour les explications pas très claires mais votre dernière formule est exactement ce que je souhaitais!!



Merci beaucoup!!!!
Messages postés
25592
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 novembre 2020
5 614
pas de quoi. Bonne route
crdlmnt