Formule Excel si cellule contient un texte + formule [Résolu]

Signaler
-
 xav30 -
Bonjour,

Je dois dans le cadre de contrôle périodique sur du matériel, réaliser un suivi :

H1 : Date du contrôle
J1 : Etat du contrôle
M1 : Durée de validité
N1 : Fin de validité

Exemple :
H1 : 01/01/2020
J1 : Conforme/Non conforme
M1 : 6 (mois)
N1 : 01/07/2020

Comment en N1 appliqué H1+M1 si J1conforme et vide si J1 non conforme

J'ai un début de piste mais excel ne prends pas la formule A1+C1
=SI(NB.SI(J1;"Conforme");"=MOIS.DECALER(H1;M1)";"")

MERCIiiiiiiii

Configuration: Windows / Chrome 85.0.4183.121

4 réponses

Messages postés
1183
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
28 octobre 2020
117
Bonjour,
pour ajouter H1 à M1 si J1 = conforme :

=SI(J1="Conforme";MOIS.DECALER(H1;M1);"")

Mais cela doit aussi s'appliquer si J1 est Non conforme ou alors si J1 est vide !?

Par contre, que sont A1 & C1 ???

Messages postés
16275
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
29 octobre 2020
3 056
Bonjour

A1+C1 inconnus dans ta demande.....
Bonjour, je me suis mal exprimé.

J'ai un début de piste mais excel ne prends pas la formule pour mettre une date de fin de validité en fonction de la date H1 et de la durée de validité M1
=SI(NB.SI(J1;"Conforme");"=MOIS.DECALER(H1;M1)";"")
merci cela a marché, c'était une erreur de ma part dans du copier/coller.