Formule Excel si cellule contient un texte, choix multiple, résultats multiple

Signaler
Messages postés
1
Date d'inscription
dimanche 4 octobre 2020
Statut
Membre
Dernière intervention
4 octobre 2020
-
Messages postés
5525
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
30 octobre 2020
-
Bonjour à toutes et tous,

Après avoir changé de logiciel de gestion commercial, je dois réintégrer tous les articles en vente (avec toutes leurs caractéristiques respectives) de la société dans le nouveau logiciel, via un import Excel.

Le but afin de me faire gagner du temps est de créer seulement les codes article (en colonne A2), ensuite pour toutes les autres caractéristiques de l'article (les autres colonnes sur la même ligne), je renseignerais des formules Excel qu'ensuite j'étirerais sur toutes les autres lignes.

Prenons un exemple concret:

J'ai en cellule A2 le code article alphanumérique (20 caractères maximum) de l'article:

- CHPBRESNV1/2SCRD

1. CHP = réfère à la famille article "00001", champagne, une colonne est attribué au code famille de l'article

2. BRES = réfère au nom de la cuvée "Brut réserve"

3. NV = Réfère au millésime "Non vintage", une colonne est attribuée au millésime de l'article

4. 1/2 = Réfère au volume de la bouteille "0.75cl", une colonne est attribuée au volume de l'article

5. SCRD = Réfère le fait que la capsule CRD (timbre fiscal attestant le paiement des droits), une colonne est attribuée au fait que l'article possède un CRD ou non

Je voudrais mettre dans certaines colonnes de la ligne 2, une formule par colonne, formule qui me donnera un résultat en fonction d'une partie du code alphanumérique de la cellule A2.

Exemple num. 1:

- Si A2 (code article) contient "CHP", alors le résultat dans la colonne B2 (famille article) sera "0001", si A2 contient "RTF", alors le résultat dans la colonne B2 sera "0002", si A2 contient "BCH", alors le résultat dans la colonne B2 sera "0003", si A2 contient "SCU", alors le résultat dans la colonne B2 sera "0003", etc etc

Exemple num. 2:

- Si A2 (code article) contient "SCRD", alors le résultat dans la colonne C2 (CRD) sera "NON", si A2 contient "CRD", alors le résultat dans la colonne C2 sera "OUI", si A2 ne contient ni "SCRD" ni "CRD", alors le résultat dans la colonne C2 sera "".

Exemple num. 3:

- Si A2 (code article) contient "1/2", alors le résultat dans la colonne D2 (volume) sera "0.375cl", si A2 contient "1/1", alors le résultat dans la colonne D2 sera "0.75cl", si A2 contient "2/1", alors le résultat dans la colonne D2 sera "1.50cl", si A2 contient "4/1", alors le résultat dans la colonne D2 sera "300cl", etc etc.

Suis-je assez clair pour que quelqu'un puisse m'aider ? Sinon n'hésitez pas à me posez des questions.

Merci d'avance pour vos tuyaux

2 réponses

Messages postés
2833
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
31 octobre 2020
386
Bonjour,

Un fichier (test ou non), complété par des explications exhaustives (copier/coller de tes exemples) et des exemples remplis à la main, mis sur https://www.cjoint.com/ permettrait aux intervenants de répondre plus précisément à ta question. Et aussi connaitre ta version d'excel

Crdmt
Messages postés
5525
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
30 octobre 2020
503
Bonjour

Essayer ceci

B2 = =SI(GAUCHE($A2;3)="CHP";"00001";SI(GAUCHE($A2;3)="RTF";"00002";SI(OU(GAUCHE($A2;3)="BCH";GAUCHE($A2;3)="SCU");"00003";"")))

C2
=SI($A2="";"";SI(DROITE($A2;4)="SCRD";"Non";"Oui"))

D2
=SI(DROITE(GAUCHE($A2;12);3)="1/2";"0,375cl";SI(DROITE(GAUCHE($A2;12);3)="1/1";"0,75cl";SI(DROITE(GAUCHE($A2;12);3)="2/1";"1,50cl";"")))

Il serait préférable d'avoir une table des contenant pour utiliser la fonction RECHRCHEV(...)

E2
=SI(DROITE(GAUCHE(A$2;7);4)="BRES";"Brut réserve";"")

F2
=SI(DROITE(GAUCHE($A2;9);2)="NV";"Non vintage";"")

à vérifer pour être plus sûre