Récuperation de données [Résolu]

Signaler
-
Messages postés
25747
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 janvier 2021
-
Bonjour,

Je dispose d'un tableau sur Feuil 1 avec plusieurs enregistrements par date:
09/04/20 fourniseur A
09/04/20 fournisseurB
10/04/20 fournisseurX
Je souhaite récupérer de façon journalière ces informations sur feuil 2 en fonction d'une date choisie.
A la date du 09/04/20, un seul enregistrement s'affiche et non les autres, j'utilise la formule suivante: =SIERREUR(INDEX(Feuil1!$A$10:$S$2000;EQUIV($A$8;Feuil1!$A$10:$S$2000;0);9);"")
Choix de la date en A8.
Merci de m'aider





Configuration: Windows / Firefox 81.0

5 réponses

Messages postés
25747
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 janvier 2021
5 714
Bonjour
essayez avec cette formule matricielle, en supposant que votre plage va jusqu'en ligne 1000 feuil1 et que la ddate cherchée se trouve en A8 feuil2:
formule en feuil2
=SIERREUR(INDEX($B$1:$B$1000;PETITE.VALEUR(SI(Feuil1!$A$1:$A$1000=$A$8;LIGNE($A$1:$A$1000));LIGNE(A1)));"")
  • formule à entrer avec la touche enter en maintenant les touches ctrl et shift enfoncées
  • elle doit s'afficher automatiquement entre accolades dans la barre de formule
  • plage et champ à débuter en ligne 1 (sinon il faut appliquer un correctif à la suite de petite valeur, car le code fonctionne avec les N° de ligne de la feuille, pas de la plage)
  • attention aux $ aux bons endroits
  • formule assez gourmande, bien limiter au nombre de lignes utiles

revenz si souci
crdlmnt

Bonjour M. VAUCLUSE

Je ne suis pas sûr de bien comprendre, je joins donc mon fichier:

https://www.cjoint.com/c/JIDjNK6me5e

Merci
Messages postés
25747
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 janvier 2021
5 714
Re
votre fichier en retour avec les formules sur les colonnes B et C jusqu'à la ligne 100. Mais à recaler dans le code INDEX au début car je ne sais pas quelles colonnes de la base de données vous voulez ressortir (champ du code INDEX au début)
pour info:
dans votre modèle, il devait manquer le nom de feuille au début de la formule dans le code INDEX avant $B$1:$B$1000
https://mon-partage.fr/f/a5oKto61/
revenez si soucis
crdlmnt
Merci M.vaucluse

ça marche très bien
Messages postés
25747
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 janvier 2021
5 714
Pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt