Addition rapide [Résolu]

Signaler
Messages postés
8
Date d'inscription
jeudi 17 septembre 2020
Statut
Membre
Dernière intervention
18 septembre 2020
-
Messages postés
2440
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
18 septembre 2020
-
Bonjour à tous,
Je vous sollicite aujourd'hui car je rencontre un soucis sur Excel.
En effet, je dois procéder à des additions de cellules, comme montré sur la photo ci dessous, je dois additionner toutes les valeurs de a ensemble, puis toutes les valeurs de b, puis toutes les valeurs de z, etc
Impossible de le faire à la main sachant que mon tableau contient plus de 5000 lignes.
Auriez vous une solution (VBA ?) pour "automatiser" ces additions (par exemple toutes les cellules qui se nomment pareil dans la colonne "nom", on additionne leur valeur respective) et avoir les sommes plus rapidement?
En espérant avoir été assez clair..
Merci d'avance
Charles


5 réponses

Messages postés
2440
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
18 septembre 2020
1 219
Bonjour,

Pas besoin de passer par VBA. Il suffit de passer par une formule :
=SOMME.SI(A:A;"a";B:B)


Messages postés
8
Date d'inscription
jeudi 17 septembre 2020
Statut
Membre
Dernière intervention
18 septembre 2020

Merci de votre réponse.
Oui j'y ai pensé, cependant je possède plus de 5000 lignes et dans ma colonne noms, plus de 500 noms différents.
Le travail sera long c'est pour cela que je cherche un moyen de tout automatiser, si c'est possible..
Messages postés
2440
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
18 septembre 2020
1 219
C'est quand même possible toujours sans VBA.

Il suffit juste d'avoir votre tableau de Nom.

Admettons qu'en Feuil2 vous ayez votre tableau des noms en A, et vous voulez leur somme en B. en B2 rentrer:
=SOMME.SI(Feuil1!A:A;A2;Feuil1!B:B)

Après si vous voulez vraiment du VBA, un plus expert que moi passera surement par ici pour vous créer le deuxième onglet et insérer la formule ou faire cette somme.
Messages postés
8
Date d'inscription
jeudi 17 septembre 2020
Statut
Membre
Dernière intervention
18 septembre 2020

Merci beaucoup, ça fonctionne.
Messages postés
2440
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
18 septembre 2020
1 219
Vous pouvez passer par un tri sur votre tableau dans le bouton Accueil puis " Trier et filtrer"