Excel - Calcul par pourcentage et par tranche

Résolu/Fermé
ouiabsurfer Messages postés 30 Date d'inscription mardi 11 septembre 2007 Statut Membre Dernière intervention 23 octobre 2011 - 1 oct. 2007 à 07:57
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 - 8 oct. 2007 à 05:33
Bonjour,

J'ai besoin de calculer un montant par pourcentage qui variera en fonction de la tranche du chiffre.

Exemple :

1,50% (de 0 à 1 725 €)
0,50% (de 1 726 à 4 600 €)
0,25% (de 4 601 à 34 500 €)
0,10% (au dessus de 34 500 €)

Si j'ai un montant de 5000 €, je dois calculer 1725 x 1,5%(=25,87) + 2874 x 0,50 (=14,37) + 399 x 0,25 (=0,99). Ce qui fait un montant de 41,23. Est-ce qu'il y aurait une âme charitable qui pourra m'aider à trouver la formule nécessaire pour réaliser ce calcul ? En effet, cela doit me permettre d'y entrer un chiffre et d'avoir la réponse dans une autre cellule.

J'ai essayé une multitude de formules avec SI et ET mais cela fait trop de conditions pour une seule condition.

Je vous remercie par avance de toute aide sur le sujet.

39 réponses

Bonjour ouiabsurfer,

J'ai testé cette formule, ça a l'air de fonctionner, si ça peux t'aider :

=SI(A3>=1725;1725*1.5/100+SI(A3>=4600;2874*0.5/100+SI(A3>=34500;29899*0.25/100+(A3-34500)*0.1/100;(A3-4600)*0.25%);(A3-1725)*0.5/100);A3*1.5/100)

Il n'y a que des SI
16