Calcul de moyenne d'âge excel [Résolu/Fermé]

Signaler
Messages postés
1
Date d'inscription
mercredi 6 avril 2016
Statut
Membre
Dernière intervention
6 avril 2016
-
Messages postés
52509
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
25 octobre 2020
-
Bonjour à tous
J'ai un petit soucis concernant une manip excel, je souhaiterai calculer une moyenne d'âge mais ne connaissant pas toutes les fonctionnalités de ce programme j'en appelle à vos lumières
Voici l'image des données
Codialement

2 réponses

Messages postés
52509
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
25 octobre 2020
14 364
Je ne vois pas l'intérêt ni même ce que peut signifier la moyenne d'effectifs regroupés en tranches d'âge ...
Mais enfin, c'est toi qui vois !
La formule est =MOYENNE(B2:G2) et le résultat est 23 786,8
Ce nombre représente la taille moyenne d'un groupe d'âge ; en le multi-pliant par 6 on retrouve bien les 142721 personnes visées par ce pointage.

C'est bien, la retraite ! Surtout aux Antilles ... :-) 
Raymond (INSA, AFPA, CF/R)
Messages postés
52509
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
25 octobre 2020
14 364
Pour obtenir la moyenne d'âge exacte de la population, il faudrait la liste des 142721 Brestois avec leur âge.
Un résultat approximatif te sera donné par la formule
=SOMMEPROD(B3:G3;B2:G2)/SOMME(B2:G2)
après avoir inscrit en B3:G3 l'âge médian de chaque tranche, à savoir
7, 22, 37, 52, 67 et 82.
Le résultat est alors 37,8 ans !

J'espère que l'Education Nationale s'en satisfera ...

Cordialement.
Messages postés
52509
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
25 octobre 2020
14 364
Attention : si le plus vieux n'a que 90 ans, le résultat est assez proche de la réalité.
Mais s'il y a une forte proportion de centenaires dans le dernier groupe d'âge, cela fausse le résultat. Plus précisément :

Notre formule a considéré que la dernière tranche allait de 75 à 89 ans.
- On a trouvé 37,8 ans.
Si on prend l'hypothèse plus plausible qu'elle va jusqu'à 99 ans,
- le résultat devient 38,3 ans.
Et si on avait une ville avec des gens jusqu'à 109 ans,
- la moyenne atteindrait 38,7 ans !