Moyenne toutes les 3 lignes [Résolu]

Signaler
-
 AntoineDome -
Bonjour,

Voilà mon problème je voudrais réaliser une moyenne toutes les lignes. Si dessous un schéma pour vous expliquer: (
         A        B   C
1 Armand 1 M1
2 Armand 2 M1
3 Armand 3 M1
4 Bernard 4 M2
5 Bernard 5 M2
6 Bernard 6 M2
7 Clothilde 7 M3
8 Clothilde 8 M3
9 Clothilde 9 M3


Avec M1 moyenne d'Armand qui est la moyenne des valeurs dans les cellules (B1;B2;B3), donc M1=2.
Avec M2 moyenne de Bernard qui est la moyenne des valeurs dans les cellules (B4;B5;6), donc M2=4.
.....
Mon problème et que je ne parviens pas à étirer la formule de moyenne dans la colonne C pour la calculer toutes les 3 lignes.
Et ce que quelqu'un pourrait me venir en aide svp?

Merci d'avance de vos conseils
Antoine

2 réponses

Messages postés
29879
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
25 octobre 2020
6 868
Bonjour,

En C3 mettre
=SI((MOD((LIGNE());3))=0;MOYENNE(B1:B3);"")
et étirer vers le bas

Messages postés
29879
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
25 octobre 2020
6 868
Et si tu veux afficher la moyenne sur chacune des trois lignes, en C1 mettre
=SI((MOD((LIGNE());3))=1;MOYENNE(INDIRECT(ADRESSE(LIGNE();2;4)&":"&ADRESSE(LIGNE()+2;2;4)));SI((MOD((LIGNE());3))=2;MOYENNE(INDIRECT(ADRESSE(LIGNE()-1;2;4)&":"&ADRESSE(LIGNE()+1;2;4)));MOYENNE(INDIRECT(ADRESSE(LIGNE()-2;2;4)&":"&ADRESSE(LIGNE();2;4)))))
et étirer vers le bas
>
Messages postés
29879
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
25 octobre 2020

C'est exactement ce que je voulais! Je vous remercie infiniment. Je n'ai pas encore compris comment fonctionnait votre formule mais je vais m'y pencher pour en comprendre le fonctionnement. En tous cas encore merci de votre réactivité

Bonne continuation
Messages postés
23595
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
26 octobre 2020
6 424
Bonjour,

si tu n'as pas besoin de 3 fois la même moyenne, en C3 (ou C1, ou C2 à ton choix) :
=MOYENNE(B1:B3) 

sélectionne C1:C3 avant de tirer vers le bas.
Tu auras ta moyenne toutes les 3 lignes.
eric
Messages postés
29879
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
25 octobre 2020
6 868
salut,

Je comprends bien la logique, dupliquer un bloc de 3 cellules sur une zone en dessous. Mais je ne sais pas le faire, je sélectionne C1:C3 et si je clique sur l'icone dupliquer en bas, cela duplique la c1 sur les 2 autres. Comment selectionner le bloc à dupliquer, puis après la zone receptrice de la duplication et lancer la duplication ?
Messages postés
52511
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
25 octobre 2020
14 367 >
Messages postés
29879
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
25 octobre 2020

Sélectionne C1:C3, et tire la poignée de la cellule C3 vers le bas sur un multiple de 3 : 6, 9 ...30 ... 90 lignes.
Messages postés
29879
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
25 octobre 2020
6 868 >
Messages postés
52511
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
25 octobre 2020

bingo ! donc la seconde sélection vaut duplication implicite. Merci
>
Messages postés
29879
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
25 octobre 2020

Super, cela fonctionne aussi pour moi avec cette deuxième solution! Merci