Avoir la somme de dates [Résolu]

Signaler
-
Messages postés
25460
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 octobre 2020
-
Bonjour,

Si dans la colonne "B", j'ai des dates "d'entrées" durant une année complète, je voudrais que :

- dans la cellules "F4" ( Nommé Janvier ) çà me donne la somme des dates de janvier
- dans la cellules "G4" ( Nommé Février ) çà me donne la somme des dates de février
- dans la cellules "H4" ( Nommé Mars) çà me donne la somme des dates de mars
- dans la cellules "I4" ( Nommé Avril ) çà me donne la somme des dates de avril
- dans la cellules "J4" ( Nommé Mai ) çà me donne la somme des dates de mai

et ainsi de suite jusqu'à décembre.

Dans la colonne "B" le nombre de ligne n'ai pas définies.

Je souhaite si possible avoir une formule "la plus simple".

Par avance merci




Configuration: Windows / Chrome 80.0.3987.132

4 réponses

Messages postés
25460
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 octobre 2020
5 564
Bonjour
janvier, si vous avez des dates B de ligne 2 à ligne 1000
nombre de dates du même mois:
=SOMMEPROD((MOIS($B$2:$B1000)=1)*($B$2:$B1000>0)*1)
et pour les mois suivants
février:
=SOMMEPROD((MOIS($B$2:$B1000)=2)*1)
et ainsi de suite avec =3 =4 etc....
notez que l'item *($B$2:$B1000>0)n'est obligatoire qu'en janvier car sinon Excel compte une cellule vide comme Janvier
et pour éventuellement faire une somme des valeurs de C2 à C1000 du mois cherché:
=SOMMEPROD((MOIS($B$2:$B$1000)=1)*($C$2:$C$1000))

SOMMEPROD est assez lourd, mieux vaut limiter les champs en nombre de lignes (dans cet exemple de 2 à 1000)
crdlmnt

Super

Merci beaucoup
La formule est bonne mais j'ai un soucis car je les ai utilisé également pour des dates de sorties et le fait d'avoir des vides, çà bug .

Voici mon tableau pour ce soit plus clair.
https://www.cjoint.com/c/JCoqYdQpmqn

Merci pour l'aide
Messages postés
23599
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
27 octobre 2020
6 429
Bonjour,

la formule la plus simple est celle qui n'existe pas.
Avec un TCD : 0 formule.

Tableau Croisé Dynamique (TCD) : http://www.mdf-xlpages.com/modules/publisher/item.php?itemid=109
et
http://www.mdf-xlpages.com/modules/publisher/item.php?itemid=130
eric
Messages postés
25460
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 octobre 2020
5 564
Je ne sais pas d'où viennent les dates de votre modèle, mais il y a un problème de formatage dans les cellules vides entre les dates.
si vous suivez les opérations suivantes:
  • 1° entrer un 0 dans ces cellules vides. Si les cellules étaient en format date, elle devrait afficher 00/01/1900 alors qu'elles affichent le 0 seul
  • 2° une fois les cellules intercalaires remplies de 0, la formule fonctionne
  • 3° vous pouvez alors effacer les 0, et le fonctionnement reste actif

voyez le modèle joint, tableau du haut, obtenu avec cette méthode

Si toutefois vous ne pouvez pas résoudre ces problèmes de format, je vous propose une formule un peu plus complexe, voir le tableau vert dans le modèle joint avec quelques explications
revenez si soucis:
https://mon-partage.fr/f/kPykfoG8/
crdlmnt
Je pense garder la dernière solution.

Merci beaucoup et bonne soirée
Messages postés
25460
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 octobre 2020
5 564
Ok, je passe le sujet en résolu
Bonne route
crdlmnt