Problème avec APT

Résolu/Fermé
Seidel - 17 févr. 2020 à 11:47
 Seidel - 18 févr. 2020 à 01:52
Bonjour, j'ai un problème lorsque je veux supprimer, installer ou mettre à jour un packet:

Do you want to continue? [Y/n] y
dpkg: warning: files list file for package 'gnome-accessibility-themes' missing; assuming package has no files currently installed
dpkg: unrecoverable fatal error, aborting:
files list file for package 'gnome-icon-theme' contains empty filename
/usr/bin/gdbus: error while loading shared libraries: /lib/aarch64-linux-gnu/libglib-2.0.so.0: invalid ELF header
E: Sub-process /usr/bin/dpkg returned an error code (2)


Je ne sais plus du tout quoi faire...

Merci d'avance !

Configuration: Windows / Chrome 79.0.3945.130
A voir également:

7 réponses

OK ! Donc j'ai fait un
sudo mv /var/lib/dpkg/info/gnome* /home/freebox/downloads/


Puis un
sudo dpkg --configure -a


Suivi d'un
sudo apt-get autoclean


Et tout est revenu à la normale ! Pffffiou ! Merci à tous !
1
zipe31 Messages postés 36402 Date d'inscription dimanche 7 novembre 2010 Statut Contributeur Dernière intervention 27 janvier 2021 6 412
17 févr. 2020 à 15:01
Merci du retour.
0
cs_PaTaTe Messages postés 2126 Date d'inscription mercredi 21 août 2002 Statut Contributeur Dernière intervention 19 février 2021 493
17 févr. 2020 à 12:05
Bonjour,

Je commencerai déjà par :

apt update
apt dist-upgrade
apt clean


Histoire de voir, après on creusera.

Cordialement,
0
Alors avec un apt-update:

/usr/bin/gdbus: error while loading shared libraries: /lib/aarch64-linux-gnu/libglib-2.0.so.0: invalid ELF header
Reading package lists... Done
Building dependency tree
Reading state information... Done
75 packages can be upgraded. Run 'apt list --upgradable' to see them.


Avec un dist-upgrade:

dpkg: warning: files list file for package 'gnome-accessibility-themes' missing; assuming package has no files currently installed
dpkg: unrecoverable fatal error, aborting:
files list file for package 'gnome-icon-theme' contains empty filename
/usr/bin/gdbus: error while loading shared libraries: /lib/aarch64-linux-gnu/libglib-2.0.so.0: invalid ELF header
E: Sub-process /usr/bin/dpkg returned an error code (2)


et rien en sortie avec un apt clean...
0
zipe31 Messages postés 36402 Date d'inscription dimanche 7 novembre 2010 Statut Contributeur Dernière intervention 27 janvier 2021 6 412
17 févr. 2020 à 12:14
Salut,

Essaies un
dpkg --configure -a
pour commencer…
0
cs_PaTaTe Messages postés 2126 Date d'inscription mercredi 21 août 2002 Statut Contributeur Dernière intervention 19 février 2021 493
17 févr. 2020 à 12:15
Tu essais d'installer quoi ? Tu nous mets pas ta commande

Quelle version de Debian ? (de mémoire : cat /proc/version)
0
Merci pour vos réponses rapides !

Nan rien avec un
dpkg --configure -a


Ah rien qu'en faisant un apt-upgrade j'ai ces erreurs là... Impossible d'installer quoi que ce soit.

Sinon voici ma version de debian:

Linux version 4.19.0-6-arm64 (***@***) (gcc version 8.3.0 (Debian 8.3.0-6)) #1 SMP Debian 4.19.67-2+deb10u2 (2019-11-11)
0
zipe31 Messages postés 36402 Date d'inscription dimanche 7 novembre 2010 Statut Contributeur Dernière intervention 27 janvier 2021 6 412
17 févr. 2020 à 12:18
Et un
apt -f install
?
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
freebox@freebox-vm-23043:~$ sudo apt -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 75 not upgraded.
freebox@freebox-vm-23043:~$
0
zipe31 Messages postés 36402 Date d'inscription dimanche 7 novembre 2010 Statut Contributeur Dernière intervention 27 janvier 2021 6 412
17 févr. 2020 à 12:25
apt clean && apt update && apt upgrade 
?
0
Seidel > zipe31 Messages postés 36402 Date d'inscription dimanche 7 novembre 2010 Statut Contributeur Dernière intervention 27 janvier 2021
17 févr. 2020 à 12:37
freebox@freebox-vm-23043:$ sudo apt clean && sudo apt update && sudo apt upgrade
Hit:1 http://deb.debian.org/debian buster InRelease
Hit:2 http://deb.debian.org/debian buster-updates InRelease
Hit:3 http://security.debian.org buster/updates InRelease
Hit:4 http://ftp2.fr.debian.org/debian buster InRelease
Hit:5 http://deb.debian.org/debian buster-backports InRelease
Hit:6 http://repo.mysql.com/apt/debian buster InRelease
Hit:7 https://deb.nodesource.com/node_10.x buster InRelease
Hit:8 http://ftp.de.debian.org/debian buster InRelease
Hit:9 http://phoscon.de/apt/deconz buster-beta InRelease
/usr/bin/gdbus: error while loading shared libraries: /lib/aarch64-linux-gnu/libglib-2.0.so.0: invalid ELF header
Reading package lists... Done
Building dependency tree
Reading state information... Done
75 packages can be upgraded. Run 'apt list --upgradable' to see them.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
linux-image-4.19.0-8-arm64
The following packages will be upgraded:
base-files cups cups-client cups-common cups-core-drivers cups-daemon cups-ipp-utils cups-ppdc cups-server-common e2fsprogs firefox-esr firefox-esr-l10n-fa guile-2.2-libs idn2
libboost-chrono1.67.0 libboost-iostreams1.67.0 libboost-python1.67.0 libboost-random1.67.0 libboost-system1.67.0 libburn4 libcom-err2 libcups2 libcupsimage2 libegl-mesa0 libexif12
libext2fs2 libgbm1 libgl1-mesa-dri libglapi-mesa libglx-mesa0 libgnutls-dane0 libgnutls30 libidn2-0 libimobiledevice6 libmariadb3 libopenjp2-7 libpam-systemd libpython3.7
libpython3.7-dev libpython3.7-minimal libpython3.7-stdlib libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5printsupport5 libqt5widgets5 libss2 libsystemd0 libtimedate-perl
libudev-dev libudev1 linux-image-arm64 linux-libc-dev mariadb-client-10.3 mariadb-client-core-10.3 mariadb-common mariadb-server-10.3 mariadb-server-core-10.3 mesa-va-drivers
mesa-vdpau-drivers openssh-client openssh-server openssh-sftp-server python3.7 python3.7-dev python3.7-minimal python3.7-venv qemu-utils qt5-gtk-platformtheme sudo systemd systemd-sysv
tightvncserver udev
75 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 151 MB of archives.
After this operation, 228 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://security.debian.org buster/updates/main arm64 firefox-esr-l10n-fa all 68.5.0esr-1~deb10u1 [569 kB]
Get:2 http://deb.debian.org/debian buster/main arm64 base-files arm64 10.3+deb10u3 [69.8 kB]
....
Get:75 http://deb.debian.org/debian buster/main arm64 sudo arm64 1.8.27-1+deb10u2 [1,208 kB]
Get:76 http://deb.debian.org/debian buster/main arm64 tightvncserver arm64 1:1.3.9-9+deb10u1 [639 kB]
Fetched 151 MB in 1min 31s (1,660 kB/s)
Extracting templates from packages: 100%
Preconfiguring packages ...
dpkg: warning: files list file for package 'gnome-accessibility-themes' missing; assuming package has no files currently installed
dpkg: unrecoverable fatal error, aborting:
files list file for package 'gnome-icon-theme' contains empty filename
/usr/bin/gdbus: error while loading shared libraries: /lib/aarch64-linux-gnu/libglib-2.0.so.0: invalid ELF header
E: Sub-process /usr/bin/dpkg returned an error code (2)
freebox@freebox-vm-23043:$


Je sèche totalement...
0
zipe31 Messages postés 36402 Date d'inscription dimanche 7 novembre 2010 Statut Contributeur Dernière intervention 27 janvier 2021 6 412 > Seidel
17 févr. 2020 à 13:21
/usr/bin/gdbus: error while loading shared libraries: /lib/aarch64-linux-gnu/libglib-2.0.so.0: invalid ELF header
Puis
dpkg: warning: files list file for package 'gnome-accessibility-themes' missing; assuming package has no files currently installed
Faudrait voir d'essayer de réinstaller
libglib-2.0
0
J'ai essayé mais impossible d'installer ou réinstaller quoi que ce soit...
0
zipe31 Messages postés 36402 Date d'inscription dimanche 7 novembre 2010 Statut Contributeur Dernière intervention 27 janvier 2021 6 412
17 févr. 2020 à 13:34
Essaye un
dpkg --clear-avail
(trouvé ).

Voir aussi : sur gogole ;-\
0
freebox@freebox-vm-23043:~/Scripts$ sudo dpkg --clear-avail
freebox@freebox-vm-23043:~/Scripts$


Rien...
0
zipe31 Messages postés 36402 Date d'inscription dimanche 7 novembre 2010 Statut Contributeur Dernière intervention 27 janvier 2021 6 412
17 févr. 2020 à 13:39
Il faut retenter l'install après ça ;-\
0
Seidel > zipe31 Messages postés 36402 Date d'inscription dimanche 7 novembre 2010 Statut Contributeur Dernière intervention 27 janvier 2021
17 févr. 2020 à 13:46
Toujours rien...

freebox@freebox-vm-23043:~/Scripts$ sudo apt-get reinstall libglib2.0-0
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 75 not upgraded.
Need to get 1,185 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://deb.debian.org/debian buster/main arm64 libglib2.0-0 arm64 2.58.3-2+deb10u2 [1,185 kB]
Fetched 1,185 kB in 1s (1,716 kB/s)
dpkg: warning: files list file for package 'gnome-accessibility-themes' missing; assuming package has no files currently installed
dpkg: unrecoverable fatal error, aborting:
files list file for package 'gnome-icon-theme' contains empty filename
/usr/bin/gdbus: error while loading shared libraries: /lib/aarch64-linux-gnu/libglib-2.0.so.0: invalid ELF header
E: Sub-process /usr/bin/dpkg returned an error code (2)
freebox@freebox-vm-23043:~/Scripts$
0
zipe31 Messages postés 36402 Date d'inscription dimanche 7 novembre 2010 Statut Contributeur Dernière intervention 27 janvier 2021 6 412 > Seidel
17 févr. 2020 à 14:12
Il te faut éplucher les liens de gogole plus haut.
Certains sont un peu périlleux, mais bon, pour ma part je n'ai plus d'idées ;-(
0
cs_PaTaTe Messages postés 2126 Date d'inscription mercredi 21 août 2002 Statut Contributeur Dernière intervention 19 février 2021 493 > zipe31 Messages postés 36402 Date d'inscription dimanche 7 novembre 2010 Statut Contributeur Dernière intervention 27 janvier 2021
17 févr. 2020 à 14:19
Perso, cette ligne est quand même pas courante :
files list file for package 'gnome-icon-theme' contains empty filename
0
Seidel > zipe31 Messages postés 36402 Date d'inscription dimanche 7 novembre 2010 Statut Contributeur Dernière intervention 27 janvier 2021
17 févr. 2020 à 14:20
Ça fait plusieurs jours que je cherche...

C'est surtout cette erreur que je n'arrive pas à retirer:
/usr/bin/gdbus: error while loading shared libraries: /lib/aarch64-linux-gnu/libglib-2.0.so.0: invalid ELF header


J'ai beau faire toutes les commandes avec apt ou aptitude mais rien à faire...
0