Extraction de données selon un critère [Résolu]

Signaler
Messages postés
2
Date d'inscription
lundi 24 janvier 2011
Statut
Membre
Dernière intervention
6 décembre 2019
-
Messages postés
2
Date d'inscription
lundi 24 janvier 2011
Statut
Membre
Dernière intervention
6 décembre 2019
-
Bonsoir tous;

J'ai dans une colonne un ensemble de données composées de chiffres dans une feuille Excel (exemple: données de 200 chiffres comprises entre "1 et 1000", données aléatoires non linéaires). Les données dans la colonne sont susceptibles de changer.
Je souhaiterais faire une extraction automatique des chiffres supérieur à 600. Cette extraction doit etre automatisée.

Une solution ?

2 réponses

Bonsoir,
Vous pourriez essayer ce petit tableau :
https://cjoint.com/c/IKwsTBkiydK
Si j'ai bien compris la demande...
Cordialement.
Messages postés
25429
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 octobre 2020
5 550
Bonjour
Si le filtre ou le TCD ne conviennent pas (mais c'est quand même mieux)
pour un champ de A2 à A200 (à adapter)
en C2 la formule matricielle
=SIERREUR(INDEX($A$1:$A$200;PETITE.VALEUR(SI($A$2:$A$200>600;LIGNE($A$2:A$200));LIGNE(A1)));"")
à tirer jusqu'à C200
formule matricielle à entrer avec la touche enter en maintenant ctrl et shift enfoncées
elle doit s'afficher automatiquement entre accolades dans la barre de formule
notez que le champ de INDEX commencent en ligne 1pour éviter une correction, le code renvoyant le N° de ligne de la feuille, pas du champ
Pour info, ça donne ça
https://mon-partage.fr/f/TIsPn5TS/
crdlmnt



Messages postés
2
Date d'inscription
lundi 24 janvier 2011
Statut
Membre
Dernière intervention
6 décembre 2019

Merci bien