Moyenne inexacte [Résolu/Fermé]

Signaler
-
Messages postés
17297
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 octobre 2020
-
Bonjour à tous et à toutes,

Voici mon fichier : https://mon-partage.fr/f/o6ZhZsKU/

Vous m'aviez gentiment aider à faire une formule pour mes calcules de notes scolaires. Il fallait que la formule fonctionne même avec des cases vides (absences). De plus, les côtes maximales sont différentes pour chaque contrôle. Je croyais que la formule suivante était bonne, hélas elle est mathématiquement incorrecte.
=SOMMEPROD((C3:K3)/($C$2:$K$2))/NBVAL(C3:K3)

La valeur donnée en L3 est donc incorrecte, comme vérifié en L4

J'ai passé un temps fou avec formules à rallonge avec des SI(C3<>""; ..................... Sans succès

Auriez vous la grande gentillesse de m'aider encore ?


Configuration: Windows / Firefox 70.0

2 réponses

Messages postés
12873
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
4 décembre 2020
2 083
Bonsoir

Exact ! alors essaye plutôt
=SOMME(C3:K3)/SOMME.SI(C3:K3;">=0";$C$2:$K$2)
la note max d'une matière avec la cellule note laissée vide n'est pas prise en compte
la note max d'une matière avec note 0 est prise en compte

Cdlmnt
Via
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Un très grand merci, je crois que cette fois ci c'est parfait ! Juste un peu déçu de ne pas y arriver par moi même :(.
Messages postés
17297
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 octobre 2020
4 382
Bonsoir,

déjà il ne s'agit pas d'un fichier Excel mais Open Office ou Libre Office
essaye comme cela
=SOMME(C4:K4)/SOMMEPROD((C3:K3<>"")*(C$2:K$2))
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Bonsoir,

Il s'agit d'un tableur... je l'ouvre sur OpenOffice sur mon pc perso et sur Excel sur mon pc pro. Je ne crois pas que ça aie beaucoup d’importance ? La formule donnée par via55 fonctionne parfaitement (sur les deux programmes). Merci beaucoup quand même pour ta formule qui fonctionne également.
Messages postés
17297
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 octobre 2020
4 382
Re,

Certaines syntaxes Excel ne fonctionne pas sur Open Office ou sur Open Office alors que le contraire est possible il vaut donc mieux écrire une formule Open Office ou Libre Office. Il est vrai que dans ton cas ce n'est pas le cas
A+