Problème Moyenne Heures excel [Résolu/Fermé]

Signaler
Messages postés
8
Date d'inscription
jeudi 7 janvier 2010
Statut
Membre
Dernière intervention
23 juillet 2010
-
Messages postés
8
Date d'inscription
jeudi 7 janvier 2010
Statut
Membre
Dernière intervention
23 juillet 2010
-
Bonjour, je dosi réaliser un calcul de moyenne d'heures sous excel. Le problème, c'est qu'excel ne tient pas compte du format heure de mes cellules, et divise systématiquement le nombre d'heures par le nombre de minute. Exemple :

Moyenne 13h30; 15:00; 12h15 = #DIV0!

Auriez vous une solution?

Merci d'avance ,

Mal.



A voir également:

5 réponses

Messages postés
12251
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
17 mars 2021
2 624
Salut,
En ayant le même format à toutes mes cellules contenant des heures, j'obtiens un résultat...
Exemple :
A1 : 13:30 , A2 : 15:00 , A3 : 12:15
A4 : =MOYENNE(A1:A3) me donne 13:35 comme résultat
Cordialement,
-- Tout problème à sa solution. S'il n'y a pas de solution, ou est le problème? --
5
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
8
Date d'inscription
jeudi 7 janvier 2010
Statut
Membre
Dernière intervention
23 juillet 2010
5
Merci à tous pour vos réponses , j'ai finalement trouvé !
On va mettre ça sur le compte de la fatigue...

Amicalement,
Mal
Messages postés
8
Date d'inscription
jeudi 7 janvier 2010
Statut
Membre
Dernière intervention
23 juillet 2010
5
Re bonjour.

Effectivement, lorsque je met toutes les données sous le même format, cela fonctionne.

Nouveau problème : le format ne se change pas automatiquement ! Lorsque je sélectionne l'ensemble des cellules dont je dois changer le format, et que je modifie ce dernier, les données ne sont pas mises automatiquement dans ce format, je suis obligé de double-clik sur chacunes des cellules pour que la modification soit effective . . .

Existe t-il un moyen de rendre cette modification automatique?

D'avance merci,

Mal.
Messages postés
197
Date d'inscription
lundi 31 mars 2008
Statut
Membre
Dernière intervention
12 août 2012
33
je crois que c'est un prob de texte
essay ça
dans une autre colonne
la cellule B2 contient valeur : 13h30 ( avec h)

=REMPLACER(B2;3;1;":")

ça doit remplacer la lettre h par :

à la fin n oublie pas de faire copier>> collage spécial >> Valeurs pour changer les données avec H par les données avec :

bonne chance
Messages postés
197
Date d'inscription
lundi 31 mars 2008
Statut
Membre
Dernière intervention
12 août 2012
33
Moyenne 13h30; 15:00; 12h15 = #DIV0!

je crois que ce n est que du texte

pijaku ça marche