Moyenne sans cellule vide ou valeur nulle

Résolu/Fermé
yfchauer Messages postés 78 Date d'inscription mardi 11 décembre 2007 Statut Membre Dernière intervention 18 janvier 2014 - 10 août 2012 à 00:47
 Hako - 8 janv. 2021 à 14:40
Bonjour,

Bonjour à tous,
Je cherche une formule qui me permettra de calculer la moyenne d'une plage sans tenir compte des cellules vides ou ayant la valeur '0'
Ex.
calculer la moyenne de la plage (A5:L5) dans la cellule M5 avec la formule
=SI(NBVAL(A5:L5)=0;"";MOYENNE(A5:L5)
Elle fonctionne pour les cellules vides.

Comme les données sur cette plage sont importées d'une autre feuille, la moyenne est erronée, lorsque certaines cellules de la plage sont vides
mais sous-entendu avec une valeur "0"
Merci d'avance pour votre aide.


A voir également:

3 réponses

tontong Messages postés 2549 Date d'inscription mercredi 3 février 2010 Statut Membre Dernière intervention 23 avril 2024 1 054
10 août 2012 à 09:47
Bonjour,
Même si mathématiquement il est incorrect d'exclure les zéros d'une moyenne voici 3 formules:
Standard =SOMME(A1:A8)/(NB(A1:A8)-NB.SI(A1:A8;"=0"))
Matricielle {=MOYENNE(SI(A1:A8<>0;A1:A8))}
Excel2007 ou après =MOYENNE.SI(A1:A8;"<>0")
Attention aux cellules qui contiennent des formules et paraissent vides.
112
yfchauer Messages postés 78 Date d'inscription mardi 11 décembre 2007 Statut Membre Dernière intervention 18 janvier 2014 2
10 août 2012 à 11:00
merci tontong,
je viens d'essayer les 3 formules
elles correspondent à mes attentes
parfait
1
yfchauer Messages postés 78 Date d'inscription mardi 11 décembre 2007 Statut Membre Dernière intervention 18 janvier 2014 2
10 août 2012 à 18:56
Bonjour,

Merci pour votre aide, les différentes formules fonctionnent.
j'en suis ravi.
Mais je viens de constater qu'il me renvoie une division par 0 sur une ligne où aucune donnée n'est récupérée.
Comme je l'ai dit plus haut, les données sont importées d'une autre feuille.
Donc, certaines lignes peuvent n'avoir aucune donnée, en incrémentant la formule, j'ai "#DIV/0"
Maintenant, je souhaite comment ne pas avoir cette erreur.
Une fois de plus, merci pour votre aide.
0