Moyenne sans cellule vide ou valeur nulle [Résolu/Fermé]

Signaler
Messages postés
78
Date d'inscription
mardi 11 décembre 2007
Statut
Membre
Dernière intervention
13 octobre 2013
-
 Philippe -
Bonjour,

Bonjour à tous,
Je cherche une formule qui me permettra de calculer la moyenne d'une plage sans tenir compte des cellules vides ou ayant la valeur '0'
Ex.
calculer la moyenne de la plage (A5:L5) dans la cellule M5 avec la formule
=SI(NBVAL(A5:L5)=0;"";MOYENNE(A5:L5)
Elle fonctionne pour les cellules vides.

Comme les données sur cette plage sont importées d'une autre feuille, la moyenne est erronée, lorsque certaines cellules de la plage sont vides
mais sous-entendu avec une valeur "0"
Merci d'avance pour votre aide.


3 réponses

Messages postés
2324
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
23 juin 2020
844
Bonjour,
Même si mathématiquement il est incorrect d'exclure les zéros d'une moyenne voici 3 formules:
Standard =SOMME(A1:A8)/(NB(A1:A8)-NB.SI(A1:A8;"=0"))
Matricielle {=MOYENNE(SI(A1:A8<>0;A1:A8))}
Excel2007 ou après =MOYENNE.SI(A1:A8;"<>0")
Attention aux cellules qui contiennent des formules et paraissent vides.
96
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 68016 internautes nous ont dit merci ce mois-ci

>
Messages postés
2324
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
23 juin 2020

merciiiiiiiiiiiiiiiiiiiii
finalement la formule recherché
Merciiiiiiiiiiiiiiiiiiii !!!!!
cette formule marche au top !!!
Merci, c'est clair et direct
Merci beaucoup !!!
Une autre solution beaucoup plus simple dans les formules est de remplacer tout les "0" par une lettre ou "na" dans mon cas. Attention Il faut cocher la case "totalité du contenue des cellules" dans les options.

Ensuite faites la formule moyenne normal et vous pouvez l'étendre simplement.
Messages postés
2995
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
786
Salut le forum

Formule matricielle (A valider par Ctrl+Shift+Enter)
=SOMME(A1:A10/NB.SI(A1:A10;"<>0"))

Mytå
Quelle prétention de prétendre que l'informatique est récente
Adam et Eve avaient déjà un Apple ! [MsProject 2003(FR), Excel 2003-2007(FR)]
Messages postés
78
Date d'inscription
mardi 11 décembre 2007
Statut
Membre
Dernière intervention
13 octobre 2013
2
Bonjour Mytå,

Merci de la réponse,
Le résultat n'est pas correct si l'une cellule est vide dans la plage
Par contre la formule est correcte pour les cellules avec valeur '0'