TABLEAU : la plus ancienne date [Résolu]

Signaler
Messages postés
32
Date d'inscription
jeudi 10 septembre 2015
Statut
Membre
Dernière intervention
14 décembre 2019
-
Messages postés
32
Date d'inscription
jeudi 10 septembre 2015
Statut
Membre
Dernière intervention
14 décembre 2019
-
Salut à tous !

J'ai créé un tableau sur excel avec 2 colonnes : date (colonne B) et catégorie (colonne D).
Je dois trouver la plus ancienne date selon la catégorie.

Ma formule est la suivante :
=SOMMEPROD(MIN((D6:D1000="Carburant")*B6:B1000))
Elle devrait m'afficher 23/09/2019, or le résultat est 30/12/1899 !

Comment puis-je procéder ? Merci pour votre aide précieuse !

1 réponse

Messages postés
25159
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
5 344
Bonjour
essayer en matricielle (à entrer avec la touche enter en maintenant les touches ctrl et shit enfoncées:
=MIN(SI(D6:D1000="carburant";B6:B1000))
la formule doit s'afficher automatiquement entre accolades dans la barre e formule si elle est entrée correctement
crdlmnt
Messages postés
32
Date d'inscription
jeudi 10 septembre 2015
Statut
Membre
Dernière intervention
14 décembre 2019
1
Merci pour la réponse, sa fonctionne !

En revanche j'aimerais comprendre pourquoi ma formule ne marche pas ! La même formule SOMMEPROD() (citée dans mon 1er post) avec MAX() fonctionne très bien, mais pas avec MIN()...

=SOMMEPROD(MAX((D6:D1000="Carburant")*B6:B1000)) --> affiche bien la date la plus récente
=SOMMEPROD(MIN((D6:D1000="Carburant")*B6:B1000)) --> n'affiche pas la date la plus ancienne (affiche 30/12/1899)
Messages postés
32
Date d'inscription
jeudi 10 septembre 2015
Statut
Membre
Dernière intervention
14 décembre 2019
1
Pour information, j'ai trouvé une autre formule intermédiaire non matricielle qui affiche la bonne date :
=MIN.SI.ENS(D6:D1000;B6:B1000;"Carburant")