Calculs differents si non vide [Résolu/Fermé]

Signaler
-
 mogwai -
Bonjour,

je vous explique mon problème je suis un néophyte d'excel et j'ai besoin de votre aide pour une formule que je n'arrive pas a faire j’espère que vous pourrez m'aider.

j'ai une opération a faire dans une seule cellule mais elle n'est pas la même suivant laquelle est rempli, en gros:

Dans la case C6 je dois mettre

si A1 et A6 sont remplis alors =ABS A1-A6

si A1 et B6 sont remplis alors =ABS A1 + B6

si B1 et A6 sont remplis alors =ABS B1 + A6

et si B1 et B6 sont remplis alors =ABS B1- B6

je ne peux avoir que deux cases remplis a chaque fois.

1 réponse

Messages postés
2775
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
22 septembre 2020
731
Bonjour,

Cette formule devrait convenir :

=SI(ET(A1<>"";A6<>"");ABS(A1-A6);SI(ET(A1<>"";B6<>"");ABS(A1+B6);SI(ET(B1<>"";A6<>"");ABS(B1+A6);SI(ET(B1<>"";B6<>"");ABS(B1-B6);""))))

Cordialement
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60921 internautes nous ont dit merci ce mois-ci

Merci papy ça marche parfaitement t'es en chef!!