Cumul de nombre impair [Fermé]

Signaler
-
Messages postés
52285
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 septembre 2020
-
Bonjour,

maintenant je voudrais indiquer le nombre de cellule impair dune ligne et afficher ce total dans la cellule
attenante la ligne de calcul; est ce possible sur plusieurs lignes?
merci pour vos réponses
Configuration: Windows / Edge 17.17134

2 réponses

Messages postés
2747
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
19 septembre 2020
371
Bonjour à tous,

Essaye
=SOMMEPROD(--(MOD(A1:H1;2)=1)) pour le résultat sur une plage A1:H1
que tu peux descendre sur plusieurs lignes.

A adapter suivant ta plage

Crdlmt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 61000 internautes nous ont dit merci ce mois-ci

je n arrive pas a faire trier
merci
bsr je n arrive pas a faire fonctionner
cordialement
Messages postés
52285
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 septembre 2020
14 079
Trier quoi ? Faire fonctionner quoi ?

J'attire ton attention sur le fait qu'il y a DEUX signes moins accolés, devant MOD !
= S O M M E P R O D ( - - ( M O D ( A 1 : H 1 ; 2 ) = 1 ) )
Messages postés
25298
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2020
5 478
Bonjour
en variante si le deux tirets ne fonctionnent pas:
=SOMMEPROD(( MOD(A1:H1;2)>0)*1)
mais en principe les deux fonctionnent
voir ici
https://mon-partage.fr/f/plS3Uvxl/
crdlmnt
super merci les gars pour le total des nombres impairs ça fonctionne super
maintenant si vous pouviez m'aider dans mon autre demande se serait super un grand merci d'avance
Messages postés
25298
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 septembre 2020
5 478
suffit de formuler la demande, dans un nouveau fil pour ne pas se perdre
Messages postés
52285
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 septembre 2020
14 079
La fonction SOMME.PROD ne s'applique qu'à une seule plage à la fois.
Il te faudrait donc effectuer une addition ; c'est simple, mais ça peut devenir fastidieux s'il y a plusieurs dizaines (ou centaines, ou milliers) de lignes !
=SOMMEPROD(--(MOD(A1:H1;2)=1)) + SOMMEPROD(--(MOD(A2:H2;2)=1))+ SOMMEPROD(--(MOD(A3:H3;2)=1)) + SOMMEPR ...
Mais il est plus simple de recopier vers le bas la formule saisie en J1; puis de faire la somme de la colonne J ...