Si cellule contient tel texte, déduire 1 d’une autre cellule

Fermé
Signaler
-
Messages postés
23
Date d'inscription
vendredi 22 janvier 2016
Statut
Membre
Dernière intervention
7 avril 2019
-
Bonjour

J’essaie tant bien que mal de trouver la formule appropriée pour ce que je veux faire.

Alors, j’aimerais qu’à chaque fois que les cellules D5 à D23 contiennent le mot « canot » que la cellule D26 = C26-1

J’ai trouvé cette formule;
=SI(ESTNUM(CHERCHE(“Canot”;D5:D23);C26-1;C26)

Cela fonctionne mais on déduit une seule fois -1 et non chaque fois que les cellules contiennent Canot.

Merci!!

5 réponses

Messages postés
2755
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
10 janvier 2022
1 713
Bonjour,

Essayez cette formule en D26:
=C26-NB.SI(D5:D23='*Canot*')
1
Messages postés
1953
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
12 août 2021
151
Bonjour,

Presque...
=C26-NB.SI(D5:D23;"*Canot*")

A+
1
Messages postés
3413
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
21 janvier 2022
498
Bonjour,

Je n'ai pas compris ce que tu veux faire
je te mets une solution ..........
https://www.cjoint.com/c/ICBoQAWNuEU

Crdlmt
1
Messages postés
23
Date d'inscription
vendredi 22 janvier 2016
Statut
Membre
Dernière intervention
7 avril 2019
5
Bonjour
Grand merci pour vos réponses.

Il semblerai que je sois bien moins doué que vous ne le pensiez.
diablo13800, Zoul67
J'ai essayé de copier coller vos formules sans résultat, pourquoi en D26.
DjiDji59430
Je ne comprend pas le sens de la solution... désolé.
Comment ajouter les différents mot en plus des valeurs horaires.

Je ne sais pas définir en terme Excel:
En plus du calcul des heures hebdomadaire que j'ai fait en colone G de chaque dimanche de chaque semaine.

En colone J le total de chaque dimanche passés et inclus de:
Si le total d'une semaine est supérieur ou égal à 36 heures et inférieur ou égal à 44 heures l'indiquer dans tel cellule (le nombre d'heure entre 1 et 9) de la semaine puis additionner ces cellules qui forment un mois puis qu'elles s’additionnent au fur et à mesure des cellules qui font l'année.
du 1er mai au 30 avril

En colone H le total de chaque dimanche de chaque semaine sur un mois calendaire.
Si le total d'une semaine est supérieur ou égal à 45 heures et inférieur ou égal à 48 heures l'indiquer dans tel cellule (le nombre d'heure entre 1 et 4) de la semaine puis additionner ces cellules qui forment un mois pour que j'ai un résultat mensuel.

Je ne sais pas si se sera beaucoup plus clair...
Merci d'avance à tous ;-))
0
Messages postés
1953
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
12 août 2021
151
Bonjour compatriote,

Tu te trompes de page, je crois. La question n'est pas de toi...

A+
0
Messages postés
23
Date d'inscription
vendredi 22 janvier 2016
Statut
Membre
Dernière intervention
7 avril 2019
5
Oups... Désolé
0
Merci à tous!!! Ça fonctionne :)
0