Installation de Matplotlib

[Fermé]
Signaler
-
Messages postés
321
Date d'inscription
lundi 4 juillet 2016
Statut
Membre
Dernière intervention
17 juin 2019
-
Bonjour,

Je suis actuellement en Terminale.

Ayant pris la spécialité ISN, mon projet pour le Bac est sur le thème de la stéganographie (manipulation d'images en y cachant du texte dans les valeurs de pixels)

Pour mon programme nous avons besoin de Matplotlib, ce dernier fonctionne très bien sur les ordinateurs du lycée mais ni moi ni mon collègue ne l'avons sur nos PC
Malheureusement cela fait plusieurs semaine que j'épluche des forums en essayant les solution pour l'installation mais rien y fait, je n'y arrive pas.

Je travail avec Python 3.4 sur Pyzo et Miniconda sous Windows 10

Merci d'avance.

2 réponses

Messages postés
321
Date d'inscription
lundi 4 juillet 2016
Statut
Membre
Dernière intervention
17 juin 2019
36
Salut,
Juste pour savoir tu as bien rentré cette commande "pip install Matplotlib " dans une cmd ?
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
321
Date d'inscription
lundi 4 juillet 2016
Statut
Membre
Dernière intervention
17 juin 2019
36
Ok donc le problème vient vraisemblablement de ton environnement virtuel
Mince
C'est grave docteur ?
Messages postés
321
Date d'inscription
lundi 4 juillet 2016
Statut
Membre
Dernière intervention
17 juin 2019
36
Bah personnellement moi j'installe python depuis le site officiel et ne possède donc aucune dépendance avec des IDE un peu chiant. Et après si je veux créer un environnement virtuel je clone mon environnement python officiel (après moi j'utilise pycharm). Moi je te conseillerai de commencer par installer python depuis python.org avec ce lien :
https://www.python.org/ftp/python/3.7.3/python-3.7.3-amd64.exe
Lors de l'installation (au début) coches PATH tout en bas et après que du next jusqu'à la fin de l'installation. Une fois que tu as fait ça tu peux faire un
pip install Matplotlib
et si tu tapes
python
dans la cmd et que tu rentres
import Matplotlib
Normalement plus d'erreur mais par contre miniconda n'aura tout de même pas le module. Il faudrait soi coder avec un autre programme comme Atom soit importer ton nouvelle environnement sur miniconda.
D'accord,
Merci beaucoup pour tout le temps que tu à passer pour tenter de résoudre mon problème, je n'aurai pas pu autant avancer sans
J'essayerai la méthode que tu me propose un peu plus tard car je ne suis pas chez moi toute la semaine prochaine mais merci encore.
Messages postés
321
Date d'inscription
lundi 4 juillet 2016
Statut
Membre
Dernière intervention
17 juin 2019
36
D'accord et il n'y a pas de problème, si tu as d'autres questions hésites pas je viens assez souvent sur CCM et si hésites pas non plus a me tenir au courant. Bonne soirée
Bonjour,
Je me permet d'apporter plus de précisions à ma requête.
Je constate en essayant d'installer d'autres module (Tkinter par exemple) que je ne les possède pas non plus, et que je ne peut pas les installer.

Voici le message d'erreur que Pyzo m'affiche lorsque j'essaye d'importer Matplolib ou tout autre module :

>>> pip install Matplotlib

pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available.

Collecting Matplotlib
Retrying (Retry(total=4, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError("Can't connect to HTTPS URL because the SSL module is not available.")': /simple/matplotlib/

[...]

Je vous passe le bla bla mais il réessaye 3 foi la manipulation.

[...]

Retrying (Retry(total=0, connect=None, read=None, redirect=None, status=None)) after connection broken by 'SSLError("Can't connect to HTTPS URL because the SSL module is not available.")': /simple/matplotlib/


Could not fetch URL https://pypi.org/simple/matplotlib/: There was a problem confirming the ssl certificate: HTTPSConnectionPool(host='pypi.org', port=443): Max retries exceeded with url: /simple/matplotlib/ (Caused by SSLError("Can't connect to HTTPS URL because the SSL module is not
available.")) - skipping

Could not find a version that satisfies the requirement Matplotlib (from versions: )

No matching distribution found for Matplotlib pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available.

Could not fetch URL https://pypi.org/simple/pip/: There was a problem confirming the ssl certificate: HTTPSConnectionPool(host='pypi.org', port=443): Max retries exceeded with url: /simple/pip/ (Caused by SSLError("Can't connect to HTTPS URL because the SSL module is not available.")) - skipping

Je constate qu'il s'agit d'un problème de SSL
Mais étant débutant en programmation, et même en essayant de me documenter je ne parvient pas à cerner la source du problème

Merci par avance