Somme conditionnelle horizontal/vertical Excel 365

[Résolu/Fermé]
Signaler
Messages postés
6
Date d'inscription
mardi 5 mars 2019
Statut
Membre
Dernière intervention
19 avril 2019
-
Messages postés
6
Date d'inscription
mardi 5 mars 2019
Statut
Membre
Dernière intervention
19 avril 2019
-
Bonjour,

Je n'ai pas vu de problème similaire au mien donc je vous pose la question:
J'ai un onglet excel avec :
- en ligne 1 mes quantités (variable car rappelle d'un autres onglet)
- chacune des lignes C2 à C250 correspondent a des quantités spécifique en fonction du contenant
- ma colonne A correspond aux contenants (bouteilles/poches...)
- ma colonne B à la somme des colonne C à AG, multiplier par la ligne 1 (somme des contenant en fonction des quantités)

J'ai utilisé en B2 =Somme( C1*C2+D1*D2+... ) mais ayant trop de colonne, c'est long et fastidieux. Est ce qu'il existe une formule pour faire en sorte de le faire automatiquement?
Je souhaite tirer cette formule sur toute ma colonne B.



Avez vous une idée?
Je peux vous fournir un tableau si besoin pour être plus claire


Merci a vous :)

2 réponses

Messages postés
26232
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 octobre 2021
6 087
Bonjour
voyez avec, en B2:
=SOMMEPROD(($C$1:$AG$1)*(C2:AG2))
crdlmnt
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
6
Date d'inscription
mardi 5 mars 2019
Statut
Membre
Dernière intervention
19 avril 2019

Bonjour,

Parfait!!
Merci bien, j'ai pas pensé à utiliser cette formule, j'ai essayé ça fonctionne.

Bonne journée
Bonjour Vince 7492,

Es tu certain de tes numéros de ligne car tu écrits; J'ai utilisé en B2 =Somme( C1*C2+D1*D2+... ) , a la vue de ton tableau ta formule se trouve en B3 et à la place de C2 et D2 qui sont des cellules vides ce devrait être C3 et D3

papychipie
Messages postés
6
Date d'inscription
mardi 5 mars 2019
Statut
Membre
Dernière intervention
19 avril 2019

Bonjour Papychipie,
Effectivement j'ai sauté une ligne dans mon tableau c'est bien en ligne 3