Formule Excel si cellule contient un texte [Résolu/Fermé] [Résolu/Fermé]

Signaler
Messages postés
100
Date d'inscription
lundi 7 janvier 2019
Statut
Membre
Dernière intervention
17 septembre 2020
-
Messages postés
2810
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
14 octobre 2020
-
Bonjour à tous.

Ceci est mon tout premier post, je me suis inscris il n'y a pas longtemps.

Voila après des recherches sur le net, je n'y arrive toujours pas.

Sur le fichier ci-joint, j'ai une valeur en E2 (95,00€) et une autre en B3 (- 5,00€).

Ce que je souhaiterais faire c'est dans la cellule E3, je souhaites dire :

"Si il y a une valeur dans la cellule B3, alors faire E2-B3."

Et après je déroulerais celle-ci, et par exemple en cellule E4 j'aurais :

"Si il y a une valeur dans la cellule B4, alors faire E3-B4."

Si quelqu'un pourrait m'aider à réaliser cela, je lui serais très reconnaissant.

Je vous remercie.

Cordialement.

3 réponses

Messages postés
2810
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
14 octobre 2020
753
Bonjour,
Pourquoi (Résolu/Fermé) dans le titre ???

Je suppose que s'il n'y a rien en B3 c'est la somme en E2 qui doit s'inscrire.

Attention en B3 il ne faut pas inscrire les nombres en négatif sinon E2(+95,00)-B3(-5,00) équivaut à ajouter les deux sommes le résultat serait 100,00 et non 90,00.

Je propose en E3 =si(B3<>"",E2-B3;E2) et utiliser la poignée de recopie pour incrémenter la formule vers le bas.

Cordialement
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
100
Date d'inscription
lundi 7 janvier 2019
Statut
Membre
Dernière intervention
17 septembre 2020

Bonjour.

Le titre car j'ai copié/collé d'un autre site, j'ai zappé de l'enlever...

La réponse est bonne (j'ai juste inversé le signe, pour que la formule prenne en compte les nombres négatifs [=si(B3<>"",E2+B3;E2)]

Seul bémol, vu que ce que je fais c'est un cahier de compte, et que je rentrerai mes valeurs au fur et à mesure, je veux que par exemple en E4, si je n'ai pas encore rempli en B4, que la case soit vide, et non que ça m'affiche le le montant restant (voir ci-joint).

Si vous avez une solution à ce tout petit souci, je suis preneur, et encore merci pour cette réponse.

Cordialement.

Messages postés
2810
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
14 octobre 2020
753
Dans ce cas il faut prendre la formule proposée par JCB40 (Salutations) en remplaçant le - pas +

Cordialement
Messages postés
2076
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
14 octobre 2020
341
Bonjour
Un exemple
https://www.cjoint.com/c/IAhp02kyQLk
Cordialement
Messages postés
100
Date d'inscription
lundi 7 janvier 2019
Statut
Membre
Dernière intervention
17 septembre 2020

Bonjour à tous.

Voila, après des recherches j'ai trouvé la fonction "ESTVIDE" sous Excel.

J'ai donc réalisé la formule suivante dans la cellule E3 :

=SI(ESTVIDE(B3);"";E2+B4.

Le + permet de comprendre les nombres négatifs.

Merci à PapyLuc51 de m'avoir mis sur la piste.

Si vous avez des questions, je saurais peut-être vous répondre/expliquer.

Cordialement.