Application par défaut : firefox inexistant [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
jeudi 18 janvier 2018
Statut
Membre
Dernière intervention
18 janvier 2018
-
Messages postés
13159
Date d'inscription
dimanche 14 juin 2015
Statut
Contributeur
Dernière intervention
22 juillet 2020
-
Bonjour,
J’utilise firefox comme navigateur depuis un bon bout de temps mais il n'était pas encore définit comme étant mon navigateur par défaut.
J'ai essayé de le mettre par défaut dans les paramètres W10 mais il ne figure pas dans les choix de la liste (voir capture d'écran) alors qu'il est bien installé et fonctionnel sur mon ordinateur.



Je ne sais pas d'où ça vient mais j'espère que vous saurez m'orienter.
Merci d'avance.

5 réponses

Messages postés
179285
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
23 juillet 2020
21 560
Salut,

Désinstalle Firefox et réinstalle le.
Et sinon pour mettre Firefox ou Chrome par défaut sur Windows 10 : Windows 10 : impossible Google Chrome/Firefox navigateur par défaut.

2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57815 internautes nous ont dit merci ce mois-ci

Messages postés
2
Date d'inscription
jeudi 18 janvier 2018
Statut
Membre
Dernière intervention
18 janvier 2018

Ça fonctionne merci !
Messages postés
179285
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
23 juillet 2020
21 560 >
Messages postés
2
Date d'inscription
jeudi 18 janvier 2018
Statut
Membre
Dernière intervention
18 janvier 2018

de rien =)
Messages postés
13159
Date d'inscription
dimanche 14 juin 2015
Statut
Contributeur
Dernière intervention
22 juillet 2020
5 229
Bonjour ,

J 'ai également eu ce Problème

Je ne sais pas d 'ou viens ce bug du moment
D 'autres intervenants seront peut être impactés

Solution :

Dans mon cas un simple redémarrage à suffit

J 'ai ensuite relancé Firefox et une boite de dialogue demande si vous voulez faire de Firefox votre navigateur par défaut

Avant de cliquer sur la case → Faire de Firefox mon navigateur par défaut
J'ai décoché la petite case → Toujours effectuer cette vérification au Démarrage de Firefox
C 'est inutile de cocher cette case

La page Paramètres avec Windows 10 s 'ouvre automatiquement et on visualise que Firefox est bien revenu comme navigateur par Défaut.

Cela pourrait éviter une réinstallation de Firefox



De plus il avait aussi disparu dans panneau de configuration → choisir les paramètres par défaut

Maintenant revenu on peut choisir les paramètres par défaut en cochant ou décochant des cases

Pour y accéder:

Touches clavier Windows + x ou clic droit sur le bouton Démarrer puis Exécuter et copier/coller cette commande:

control /name Microsoft.DefaultPrograms /page pageDefaultProgram

Puis OK

Page Programme par défaut.



Choisir les paramètres par défaut



Si au même point du départ il faut passer Speedyfox ce que j 'ai également fait
En fait je le passe avant de fermer le PC à chaque fois

De plus c 'est un bon entretien pour Firefox , mais aussi pour Google Chrome ,Opera , Vilvaldi

Ps :C 'est une solution à tester avant de réinstaller Firefox
Si réinstallation , il faut penser à sauvegarder ses marque-pages si le profils de Firefox est supprimé.

Messages postés
2
Date d'inscription
dimanche 5 août 2018
Statut
Membre
Dernière intervention
6 août 2018

Bonjour,
J'ai un problème similaire depuis la mise à jour de Firefox Quantum. Firefox a toujours été mon navigateur par défaut depuis des années, mais là, je n'arrive plus à le mettre par défaut!

Chaque fois que j'ouvre Firefox, il me demande si je veux le définir par défaut, j'accepte, mais Firefox n'apparaît pas dans la liste des choix offerts.

Si je vais dans le coin en haut à droite de Firefox, dans options/général, j'ai coché "Toujours vérifier que Firefox est votre navigateur par défaut". Il m'écrit : "Firefox n’est pas votre navigateur par défaut". Quand je clique sur Définir par défaut, Firefox n'apparaît pas dans la liste des choix offerts.

Si je vais dans Panneau de configuration\Tous les Panneaux de configuration\Programmes par défaut\Définir les programmes par défaut et bien Firefox n'apparaît toujours pas dans cette liste.

Et pourtant, je vous écris cette question dans Firefox qui est bien installé sur mon ordi depuis des années! J'ai Windows 8.

J'ai essayé de désinstaller Edge, mais il n'était déjà pas sur mon ordi.

J'ai été sur le site de Firefox et j'ai fait "Réparer Firefox", puis j'ai reparti l'ordi. Ça n'a rien changé.
Messages postés
179285
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
23 juillet 2020
21 560
Salut,

Quand je clique sur Définir par défaut, Firefox n'apparaît pas dans la liste des choix offerts.

Désinstalle et réinstalle Firefox.
Messages postés
13159
Date d'inscription
dimanche 14 juin 2015
Statut
Contributeur
Dernière intervention
22 juillet 2020
5 229
Bonjour ,

Essaies cette astuce:
Mets le raccourci l 'icône de Firefox sur le Bureau si ne ne l 'as pas fais
Clic droit sur le raccourci de Firefox → Exécuter en tant qu'administrateur
Va dans les options → Toujours vérifier que Firefox est votre navigateur par défaut

Ou :
Ouvre les Paramètres avec la barre de charme
Dans le champs de recherche tape → panneau configuration
configuration de programme par défaut-->configurer un programme par défaut -->tu clic sur le programme sur ta gauche et tu clic en bas mettre par défaut.

Ou encore:
Tape défaut dans l’écran de démarrage et cliquez sur Programmes par défaut.
Dans la fenêtre Programmes par défaut, clique sur Définir les paramètres par défaut de l’accès aux programmes et de l’ordinateur.
Sélectionne l’option Personnalisée
Sélectionne → Mozilla Firefox

Ps: Passe par Panneau de configuration si tu n 'y arrive pas.
Source ici



A+
Messages postés
2
Date d'inscription
dimanche 5 août 2018
Statut
Membre
Dernière intervention
6 août 2018

Bonjour,
Merci d'avoir pris le temps de répondre, c'est apprécié. Par contre, comme je le décrivais, j'ai essayé les 3 options que vous proposez, mais dans aucun des cas Firefox apparaît dans la liste des choix qui me sont offerts comme navigateur par défaut. Je vois bien que dans votre cas Firefox figure sur la liste, mais pas pour moi.

C'est comme si Windows ne reconnaissait plus que Firefox est là depuis la mise à jour même s'il y est bel et bien.
Messages postés
179285
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
23 juillet 2020
21 560 >
Messages postés
2
Date d'inscription
dimanche 5 août 2018
Statut
Membre
Dernière intervention
6 août 2018

Comme indiqué précédemment, désinstalle puis réinstalle Firefox.
Messages postés
13159
Date d'inscription
dimanche 14 juin 2015
Statut
Contributeur
Dernière intervention
22 juillet 2020
5 229
Prends la solution de Malekal que je salue

Sauvegarde tes Marques-pages au préalabre

Passe par panneau de configuration → programmes et fonctionnalité → désinstaller un programme
Ou bien utilise Revo
Lors de la désinstallation sélectionne scan complet et coche toutes les cases et tu supprime tout
il te resteras 1 seul fichier ou dossier à supprimer
Pour cela il te faut afficher les dossiers et fichiers cachés comme ceci
Va dans le disque local C → Programme file (x86)
Supprime → Mozilla → service Mozilla
Vérifies et supprime les répertoires Google si tu les vois
C:\utilisateurs\ton nom d'utilisateur\AppData\Roaming→ Google
C:\utilisateurs\ton nom d'utilisateur\AppData\Local → Google
C:\Programmes → Google

Cache de nouveau les dossiers et fichiers cachés
Fais un nettoyage disque Windows
Redémarre le PC
Réinstalle Firefox → ici
A+
Messages postés
13159
Date d'inscription
dimanche 14 juin 2015
Statut
Contributeur
Dernière intervention
22 juillet 2020
5 229
Je t 'ai donné la procédure pour désinstallé Google Chrome dans les dossiers cachés

Pour Firefox
Avec Revo
Lors de la désinstallation sélectionne scan complet et coche toutes les cases et tu supprime tout
il te resteras 1 seul fichier ou dossier à supprimer
Pour cela il te faut afficher les dossiers et fichiers cachés
Va dans le disque local C → Programme file (x86)
Supprime → Mozilla → service Mozilla
Vérifies et supprime les répertoires Mozilla si tu les vois:
C:\utilisateurs\ton nom d'utilisateur\AppData\Roaming→ Mozilla
C:\utilisateurs\ton nom d'utilisateur\AppData\Local → Mozilla
C:\Programmes → Mozilla

C 'est seulement les 3 dernières lignes Mozilla à la place de Google