Calculer une moyenne SI plusieurs conditions [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
mardi 16 janvier 2018
Statut
Membre
Dernière intervention
16 janvier 2018
-
Messages postés
25953
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 avril 2021
-
Bonjour, J'ai un tableau synthétisant des indicateurs sur une feuille nommée "DATA".





Je souhaiterais calculer des indicateurs sur une autre feuille du même fichier (nommée "synthèse").

La condition est la suivante : si DATA!(L6:L229) se produit en janvier ET DATA!(G6:G229) = "TOURELLES" ; Alors : calculer
la Moyenne de DATA!(I6:I229)

Quelle est la formule ?
s'agit-il d'un si(.....) ou d'un moyenne.ens.si ?




Je n'arrive pas à intégrer la notion de "si un évènement se produit en janvier" ; idem pour février ...
A voir également:

1 réponse

Messages postés
25953
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 avril 2021
5 866
Bonjour
dans le bon sens:

=MOYENNE.SI.ENS(I6:I229;L6:L229;"janvier";G6:G229;"TOURELLES")
notez que avec ce code le champ à calculer se place au début, contrairement au code MOYENNE.SI
mais ceci suppose qu'en L vous avez bien des mois indiqués en texte et non en date?

S'il s'agit de dates, voir, par exemple est entre autre

=SOMMEPROD((MOIS(L6:L229)=1)*(G6:G229="TOURELLES")*(I6:I229))/SOMMEPROD((MOIS(L6:L229)=1)*(G6:G229="TOURELLES"))


crdlmnt
Messages postés
2
Date d'inscription
mardi 16 janvier 2018
Statut
Membre
Dernière intervention
16 janvier 2018

Bonjour,
Pour la première formule : le résultat m'indique #DIV/0! j'ai donc changé le format de (L6:L229) pour écrire les dates en toutes lettres.
Rien ne change; toujours ce fameux DIV/0!



La 2e formule fonctionne mais ne calcule pas un résultat de moyenne
J'ai mis 2 valeurs tests : (150 en I8) et (100 enI10).

Le résultat obtenu avec la 2e formule est de 10.86;


Une précision sur la condition :"alors calculer moyenne de I6:I229 EN DIVISANT PAR LE NOMBRE DE VALEURS QUI CORRESPONDENT AUX CONDITIONS "
et non par le nombre de valeur totale
Y a -t-il moyen que je vous transfere le fichier par email ?
Messages postés
25953
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 avril 2021
5 866
suffit de le déposer ici:
http://mon-partage.fr
et revenir coller le lien créé sur le site

pour infos:
la première formule ne peut fonctionner qu'avec les mois inscrit en texte, en toutes lettres, pas avec des dates
la seconde devrait donner le résultat correspondant au mois en L si c'est une date et au texte TOURELLE en G
notez que si vous avez des cellules vides ou des textes en L, pour Excel, c'est le mois de janvier, c'est bizarre, mais c'est comme ça
voyez ici:
https://mon-partage.fr/f/fu9V1cJO/
à vous lire
crdlmnt