Somme par rapport à des critères [Résolu/Fermé]

Signaler
-
 jéjé -
Bonjour,

J'ai dans :

Colonne A des accessoires ( Assiettes, couverts, verres, plats, bols)
Colonne B des noms
Colonne D des noms identiques à la colonne B mais qui vienne d'une autre feuille ( Base de données ) du même classeur
Colonne E ( Correspond au total d'Assiettes )
Colonne F ( Correspond au total de couverts )
Colonne G ( Correspond au total de verres )
Colonne H ( Correspond au total de plats )
Colonne I ( Correspond au total de bols )

Je souhaiterais avoir la formule pour que dans les colonne E, F, G, H et I, il y est la somme qui correspond à chaque ustensiles de la colonne A , qui on un nom identique entre les colonnes B et D.

J'espère être cohérent dans mes explications.
J'ai fait une capture écran du tableau excel, mais je ne sais pas la mettre, désolé.

Par avance merci pour votre aide.


3 réponses

Messages postés
806
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
16 mai 2020
160
Bonjour,
Utilise https://www.cjoint.com/ pour mettre un classeur exemple et non une image

Bonjour,

voilà et merci

http://www.cjoint.com/c/GLlkgUFU6fL
Messages postés
806
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
16 mai 2020
160
Re,

Si j'ai compris
A tester
https://www.cjoint.com/c/GLlkorVRXJX
Messages postés
17193
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
14 mai 2020
4 056
Bonjour,

Ou peut être comme cela, formule à coller en E2

=SOMMEPROD(($B$2:$B$11=$D2)*($D$2:$D$11=$D2)*($A$2:$A$11=E$1))

formule à incrémenter vers le bas puis sur la droite
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...

Merci à M-12 se serait la bonne formule

Merci aussi Mike-31 pour la réponse