RECHERCHE V AVEC DEUX CONDITIONS [Résolu/Fermé]

Signaler
Messages postés
35
Date d'inscription
mardi 27 juin 2017
Statut
Membre
Dernière intervention
30 juin 2020
-
Messages postés
25718
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 décembre 2020
-
bonjour, j'ai besoin de vous

je voudrais savoir comment faire une recherche V avec deux conditions:
SI dans la feuille 1 la cellule A1&B2 = la feuille 2 cellule A1&B2 OU PEU IMPORTE SON CLASSEMENT AU NIVEAU DES LIGNEs, copie le commentaire de la 2 deux de cette ligne vers la feuille 1

merci pour votre réponse
A voir également:

2 réponses

Messages postés
25718
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 décembre 2020
5 690
Bonjour
voila ce que ça donne, avec quelques exemples plus "typiques" rajoutés
https://mon-partage.fr/f/7DQHSkre/
crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 66686 internautes nous ont dit merci ce mois-ci

Messages postés
25718
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 décembre 2020
5 690
Bonjour

votre demande n'est pas très claire, il y a beaucoup de deux dans votre texte

si on suppose les conditions ci dessous (à adapter)

feuil1:
valeurs à trouver A1&B2

feuil2
colonne de recherche: A1:A100 pour la valeur A1
B1:B100 pour la valeur B2
C1:C100 pour la valeur à ressortir

la formule dans la feuil1 cellule résultat:

=SIERREUR(INDEX(Feuil2!C1:C100;EQUIV(A1&B2;Feuil2!A1:A100&Feuil2!B1:B100;0));"")

attention: formule matricielle à entrer avec la touche enter en maintenant les touches ctrl et shift enfoncées
(elle s'affiche automatiquement entre accolades dans la barre de formule)
Formule assez lourde, mieux vaut limiter les champs au nombre de ligne utile (ici 1 à 100)

si toutefois a valeur cherchée est numérique et qu'une seule ligne est concernée, vous pouvez utiliser:

=SOMMEPROD((Feuil2!A1:A100=A1)*(Feuil2!B1:B100=B2)*(Feuil2!C2:C100))
c'est un peu plus lèger

et si ça ne va pas, revenez avec plus d'explications, voire avec un modèle déposé sur:
http://mon-partage.fr
avec quelques explications et en venant coller ici le lien créé sur le site

crdlmnt
Messages postés
53005
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
5 janvier 2021
14 969 >
Messages postés
35
Date d'inscription
mardi 27 juin 2017
Statut
Membre
Dernière intervention
30 juin 2020

Bonjour à toi, ami Vaucluse.
Salut à ghnacer.

Etant donné qu'en colonne A tous les noms sont différents, tu n'as pas besoin de vérifier le prénom ...
Donne à la plage A1:D30 de la feuille2 le nom "maplaj"
En D2 de la feuille 1, saisis =RECHERCHEV(A2;maplaj;4;0) et recopie vers le bas.
-------------------------------------------------------------------------------------------------------------
Si tu risques, en réalité, d'avoir plusieurs fois le même nom en A, il faut insérer une nouvelle colonne entre A et B, et avec en B2 la formule =A2&" "&C2
Tu fais pareil dans feuille2.
Tu modifies "maplaj" pour qu'elle représente la plage B1:D30 et tu modifies la formule en E2 pour qu'elle devienne =RECHERCHEV(B2;maplaj;4;0)

Cordialement.
Messages postés
35
Date d'inscription
mardi 27 juin 2017
Statut
Membre
Dernière intervention
30 juin 2020
2 >
Messages postés
53005
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
5 janvier 2021

j'aurai peu être pas du mettre nom prénom pour illustré mon exemple par ce que dans mon fichier réel, je peux avoir des noms pareil et dans prénom, des prénom pareil.

Nb : je ne peux pas toucher le fichier ni ajouter de colonne
Messages postés
53005
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
5 janvier 2021
14 969 >
Messages postés
35
Date d'inscription
mardi 27 juin 2017
Statut
Membre
Dernière intervention
30 juin 2020

  • Déjà je n'avais pas compris, dans ta question initiale de14:22, cette histoire de cellule A1&B2 ...
  • Est-ce que tu peux avoir 2 fois le même nom ET le même prénom côte à côte ?
  • Si tu ne peux pas toucher le fichier, tu devras recopier les commentaires au clavier, l'un après l'autre. En effet par définition RECHERCHEV est conçu pour effectuer une recherche sur UN critère. Mais peut-être que quelqu'un d'autre pourra te proposer une formule avec INDEX, ADRESSE, DECALER, LIGNE ...
Messages postés
35
Date d'inscription
mardi 27 juin 2017
Statut
Membre
Dernière intervention
30 juin 2020
2 >
Messages postés
53005
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
5 janvier 2021

enfaîte pour résumer ce que je voudrais faire : c'est dire à excel de copier coller le commentaire qui se trouve dans la feuille 2 vers la feuille 1 à chaque fois qu'il trouve la même ligne dans les deux feuilles. si je me trempe pas si une recherche V à deux condition , il faut qu'il vérifie deux colonnes au même temps
Messages postés
53005
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
5 janvier 2021
14 969 >
Messages postés
35
Date d'inscription
mardi 27 juin 2017
Statut
Membre
Dernière intervention
30 juin 2020

C'est bien ce que j'ai compris, et à quoi j'ai répondu.