[word] Table des figures

[Résolu/Fermé]
Signaler
-
 lolilotte -
Bonjour tout le monde,
j'ai un petit souci sous Word (2003 XP) à la création d'une table des figures. J'ai en effet un document de 70 pages, présentant notament des tableaux, graphiques, images auxquels j'ai ajouté une légende via le menu "insertion > reference > legende. Pour rendre le tout plus cohérent, j'ai mis comme etiquette "Figure" à chacun de ces éléments. Mes légendes se positionnent donc comme je le souhaite, la numérotation est correcte (debute à 1 et se termine comme prevu) ,et j'ai pu leur appliquer le style que je voulais.

Le probleme survient à la création de la table de ces figures (via le menu insertion > table et index > table des illustrations). Là j'ai bien choisi "figure" dans le menu déroulant "légende" de la section "général". L'index qui est créé commence à 3, d'autres références sont manquantes dans la liste générée. Les éléments qui ne sont pas présent dans l'index ne sont pas de nature différente aux autres (tableau, dessin). Le fait que la table des figures ne commencent pas au premier élément est donc surprenant sachant que dans le document la numérotation part bien de 1. Peut etre ai-je ajouter des références sans aucun texte et je ne peux pas supprimer puis quelle sont invisibles. Y a t-il moyen de sélectionner ces légendes ou de regler mon probleme d'une autre manière.

Merci à vous

3 réponses

Messages postés
17214
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
3 septembre 2021
10 548
Bonjour à tous les deux

Première chose : pour afficher les codes, c'est ALT+F9
Cela permet de voir tous les champs.

Pour les numéros qui ne s'affichent pas dans la table, cela peut venir du fiat que vous avez inséré une légende pour une figure avec habillage. Dans ce cas la légende se trouve dans une zone de texte, et Word ne sait pas l'intégrer dans la table.

Pour pallier ce problème, le mieux est d'insérer les figures avec habillages dans une zone de tableau et d'y mettre également la légende.

J'ai expliqué tout ça ici :
http://faqword.free.fr/articles.php?lng=fr&pg=234

m@rina
14
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
17214
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
3 septembre 2021
10 548
Bonjour,

J'ai eu le même problème avec ma thèse il y a 2 min! (J'ai Word 2013)
Seulement pour moi la solution de m@rina n'a pas bien marché car mon logiciel Word ne me proposait que "Table" dans le menu déroulant des étiquette pour mes tableaux et plus "Tableau". Quand j'ai appliqué la méthode de m@rina, le problème s'est reposé par la suite....

Ce qui s'est passé c'est que mon étiquette "Tableau" avait du être supprimé. Il faut la remettre en cliquant sur "insérer une légende" --> "Nouvelle étiquette" --> entrer à la main "Tableau".

Puis pour faire la légende: Cliquer sur le menu déroulant de "Etiquette" sur "Tableau" et entrer le nom du tableau dans l'encart "légende" et vous verrez il y a marqué "Tableau" et plus "Table".

Pour uniformiser la numérotation si besoin: ctrl + a --> clique droit "Mettre à jour les champs" et si ca marche pas cliquez sur le numéro du tableau uniquement que vous souhaitez changer et clique droit "mettre à jour les champs" voir "Edit Field" --> cf commentaire de m@rina plus haut

voila voila
@+