Périodes de journée: matin / après-midi / soir / nuit [Fermé]

Signaler
Messages postés
801
Date d'inscription
vendredi 9 mai 2008
Statut
Membre
Dernière intervention
25 septembre 2020
-
Messages postés
23567
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 octobre 2020
-
Bonjour,
Nouveau défi:
Il faut que je répartisse des tâches selon les heures pendant la journée.
La journée est répartie en 4 tranches:
0h - 8h = Nuit
8h - 12h = Matin
12h - 18h = Après-midi
18h - 0h = Soir

À partir d'une cellule C2 =
28/06/2017 22:39
, trouver le résultat mercredi Soir

Pour le moment j'ai fait 3 autres cellules
D2:
=TEXTE((L29);"dddd")
donne mercredi
E2:
=SI(HEURE(L29)<8;"Nuit";SI(HEURE(L29)<12;"Matin";SI(HEURE(L29)<18;"Après-midi";SI(HEURE(L29)>=18;"Soir"))))
donne Soir
F2:
=D2&" "&E2
donne mercredi Soir

Y a-t-il moyen d'arriver au résultat en une seule étape?

Merci d'avance







CCM est votre ami

5 réponses

Messages postés
801
Date d'inscription
vendredi 9 mai 2008
Statut
Membre
Dernière intervention
25 septembre 2020
52
Bon, je n'y arrive pas. Dans la fonction RECHERCHEV, comment gérer l'argument Table_matrice = ?
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
23567
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 octobre 2020
6 408
Si ma formule fonctionne pourquoi vouloir la modifier ?
https://www.cjoint.com/c/GEFj7bxpBVi
Messages postés
801
Date d'inscription
vendredi 9 mai 2008
Statut
Membre
Dernière intervention
25 septembre 2020
52
Merci.

La formule d'eriiic marche :)
La formule de PHILOU10120 contient une erreur au niveau 0\"Nuit"
J'essaie de décortiquer la formule pour comprendre l'erreur. Je n'ai pas l'habitude des fonctions recherchev et mod.

CCM est votre ami
Messages postés
5518
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
7 octobre 2020
498
Bizarre je n'ai pas ce terme dans ma formule 0/"Nuit"

Pour plus de sécurité je l'ai mis en 1/100èmè / H

=TEXTE(C2;"jjjj")&" "&SI((C2-ENT(C2))*24<8;"Nuit";SI((C2-ENT(C2))*24<12;"Matin";SI((C2-ENT(C2))*24<18;"Après-midi";SI((C2-ENT(C2))*24>=18;"Soir"))))
Messages postés
23567
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 octobre 2020
6 408
Bonjour,

avec date-heure en A2 :
=TEXTE(A2;"jjjj")&" "&RECHERCHEV(MOD(A2;1)*24;{0\"Nuit";8\"Matin";12\"Après-midi";18\"Nuit"};2)

eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Messages postés
5518
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
7 octobre 2020
498
Bonjour

Essayer ceci

=TEXTE(c2;"jjjj")&" "&SI(HEURE(C2-ENT(C2))<8;"Nuit";SI(HEURE(C2-ENT(C2))<12;"Matin";SI(HEURE(C2-ENT(C2))<18;"Après-midi";SI(HEURE(C2-ENT(C2))>=18;"Soir"))))

modifié sans la fonction choisir remplacé par Texte(...)

C'est en forgeant que l'on devient forgeron. -   C'est au pied du mur que l'on voit le maçon - on apprend toujours de ses erreurs
Messages postés
801
Date d'inscription
vendredi 9 mai 2008
Statut
Membre
Dernière intervention
25 septembre 2020
52
Si, si, ça va. J'ai vu et compris les erreurs. Merci encore à tous les deux :-)

Me reste le problème du Tableau Croisé Dynamique qui classe les tranches par ordre alphabétique, donc l'après-midi avant le matin. On peut régler ça en changeant les intitulés, du genre 0-Nuit, 8-Matin, etc, mais ça fait pas propre.
Messages postés
23567
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 octobre 2020
6 408
Fais un tri manuel, déplace les étiquettes (cliqué-glissé) là où elles doivent être.
eric