Comment faire évoluer le N° INDEX COLONNE dans RECHERCHEV

[Fermé]
Signaler
Messages postés
2
Date d'inscription
mercredi 26 avril 2017
Statut
Membre
Dernière intervention
27 avril 2017
-
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
-
Bonjour,
je souhaiterais savoir comment faire augmenter le N° INDEX COLONNE dans la formule RECHERCHEV quand je fais un glisser coller de la cellule AJ7 de mon tableau vers les cellules de droite AK7, AL7, AM7, AN7, ect .....

formule située dans la cellule AJ7 de mon tableau :
=SI($AD7<>"";(RECHERCHEV($AD7;'[COMMUNICATION REFERENCE.xls]Paul ELUARD ok'!$A$6:$Y$146;7));"")
je voudrais la formule evolutive dans les cellules suivantes
dans la cellule AK7 =SI($AD7<>"";(RECHERCHEV($AD7;'[COMMUNICATION REFERENCE.xls]Paul ELUARD ok'!$A$6:$Y$146;8));"")
dans la cellule AL7 : =SI($AD7<>"";(RECHERCHEV($AD7;'[COMMUNICATION REFERENCE.xls]Paul ELUARD ok'!$A$6:$Y$146;9));"")

car lorsque je fais un glisser coller le N° INDEX COLONNE reste figé

y a t-il un symbole a rajouter ou toute autre chose

merci pour votre aide

2 réponses

Messages postés
24200
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 octobre 2021
6 929
Bonjour,

sert toi de colonne() qui te retourne le n° de colonne où est la formule.
Donc colonne()-x , x dépendant du nombre à obtenir
eric
4
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 532
Salut Éric, comment vas-tu ?
à une seconde près nous étions synchrones. ;-)
Messages postés
24200
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 octobre 2021
6 929
Salut gb,

J'ai fait un passage éclair, ce qui explique que j'ai été plus rapide ;-)
Et pour la santé ça va de mieux en mieux je trouve :-)
A+
eric
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 532
Salut Éric,
Very good, c'est bon d'être rapide comme l'éclair !
Messages postés
2
Date d'inscription
mercredi 26 avril 2017
Statut
Membre
Dernière intervention
27 avril 2017

bonsoir Eric,
tout d abord merci pour cette réponse rapide.
malheureusement l'astuce que vous m avez donné et ce je viens de tester n est pas ce que je recherche.
ce que je souhaiterais c est que le n° index colonne augmente lorsque que je fais glisser ma cellule pour étendre ma série
actuellement quand je glisse ma cellule, l index colonne reste fixe.
et je voudrais éviter de le modifier a la main en 1, 2, 3, 4 ...........,28
je ne sais pas si je m explique bien.
en principe quand on met 1 dans une cellule, 2 dans la suivante et que l on sélectionne les deux cellule et que l on glisse ca fa 1, 2, 3, 4, ..................100
un peu compliqué à expliquer.

merci quand même pour votre aide
bonne soirée
Patrice
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 532
Bonjour,

Je pense que tu n'as pas bien appliqué comme sur la formule que je t'ai mise ci-dessous car sinon cela aurais répondu à ton problème.
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 532
Bonjour,

la formule située dans la cellule AJ7 de mon tableau
=SI($AD7<>"";(RECHERCHEV($AD7;'[COMMUNICATION REFERENCE.xls]Paul ELUARD ok'!$A$6:$Y$146;COLONNE()-29));"") 

La colonne AJ étant 36 avec -29 tu obtiens 7 et en tirant vers la droite tu augmentes automatiquement.