No such file or directory

Résolu/Fermé
moise02 - 4 déc. 2016 à 16:23
 moise02 - 4 déc. 2016 à 20:23
Bonjour,


j'essaie depuis 2 jours de comprendre mon erreur mais rien y fais...

je souhaite lancer un serveur samp j'ai tout installer correctement mais lors du lancement de la commande : ./samp03svr & la commande me retourne ceci:

bash: ./samp03svr: No such file or directory


je précise que le fichier samp03svr est bien dans le dossier dans lequel je fais la commande...

en vous remerciant...

2 réponses

Peux-tu poster le résulat des commandes suivantes, dans cet ordre :

chmod +x samp03svr


uname -a


file samp03svr


ls -l


./samp03svr
2
bonjour Rocailleux,

uname -a
Linux vps 2.6.32-042stab116.1 #1 SMP Wed May 4 16:21:02 MSK 2016 x86_64 GNU/Linux

file samp03svr
bash: file: command not found


ls -l
total 2008
-rwx------ 1 serveur serveur 3777 Aug 9 2010 LICENSE
-rwx------ 1 serveur serveur 1847 Oct 14 2009 README
-rwx------ 1 serveur serveur 10936 Jan 24 2015 announce
drwx------ 2 serveur serveur 4096 Aug 13 2010 filterscripts
drwx------ 2 serveur serveur 4096 Sep 10 2009 gamemodes
drwx------ 2 serveur serveur 4096 Sep 5 2009 include
-rw------- 1 serveur serveur 0 Dec 4 10:06 nohup.out
drwx------ 3 serveur serveur 4096 Sep 28 2009 npcmodes
-rwx------ 1 serveur serveur 591652 Jul 11 2015 samp-npc
-rwx--x--x 1 serveur serveur 1416792 Jul 14 2015 samp03svr
drwx------ 4 serveur serveur 4096 Oct 12 2009 scriptfiles
-rwx------ 1 serveur serveur 319 Dec 4 10:07 server.cfg


./samp03svr
bash: ./samp03svr: No such file or directory


voilà ! merci de ta réponse.
0
Oui c'est curieux, tu es bien l'utilisateur "serveur" ? (commande whoami)

edit: euh.. c'est quel OS sur ton serveur pour que la commande file n'existe pas ?

essaye la commande "touch samp03svr"
0
Oui oui j'ai même essayer sur l'utilisateur Root et je suis sous debian 8 64 bit
0
Ton fichier samp03svr est peut-être un executable 32bit, ce qui pose un problème si tu veux l'executer sur ton système 64 bits. Je voulais vérifier ça avec la commande file... (edit: c'est sûrement ça, j'ai le même comportement quand je fais le test)

Que donne la commande :

readelf -h samp03svr
0
pareil command not found =/

existe t'il une solution pour lancer tout de même l'executable "samp03svr" 32bit sur mon debian 64 bit?
0