Problème de compilation dev Cpp

Résolu/Fermé
seckychrystopher Messages postés 3 Date d'inscription lundi 18 février 2013 Statut Membre Dernière intervention 23 février 2017 - 23 févr. 2017 à 10:01
mamiemando Messages postés 33207 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 24 juillet 2024 - 27 févr. 2017 à 10:25
Bonjour
je m'aimerais m lancer dans la programmation. J'ai donc installé la dernière version de dev-Cpp sur windows 8.1.
J'ai modifié le chemin Bin par bin dans Outils\option-compilateur.
et dans programme, j'ai modifié le chemin des applications (gcc par exemple) par c:\Dev-Cpp\bin\gcc.exe

Lorsque je lance la compilation, j'obtiens les messages d'erreurs suivants:
C:\Dev-Cpp\Projet\Makefile.win [Build Error] n\make.exe: *** [Test1.exe] Error 1
Aborted (program collect2)

!!! Besoin d'aide pour y remedier.
Merci
A voir également:

2 réponses

mamiemando Messages postés 33207 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 24 juillet 2024 7 765
Modifié par mamiemando le 23/02/2017 à 10:21
Bonjour,

Je pense que ton installation est mauvaise, le mieux serait de suivre un tutoriel. Je ne peux pas te guider sous windows (je n'utilise pas windows pour programmer) mais je t'invite à suivre ce tutoriel, qui semble suggérer que code::blocks s'installe facilement.
https://openclassrooms.com/fr/courses/1894236-programmez-avec-le-langage-c/1894601-installez-les-logiciels-necessaires-pour-programmer

Autre conseil à toutes fins utiles : le C++ n'est pas le langage le plus simple pour débuter en programmation. Personnellement je conseille de commencer par un langage plus simple genre python (pour se familiariser avec les boucles, les fonctions, etc), et après passer au C (pour se familiariser avec la gestion de la mémoire, le typage, la compilation, ...), refaire une étape par python pour découvrir la programmation objet, et enfin repasser au C++ (pour découvrir ensuite les classes, les héritages, la surcharge d'opérateur, le polymorphisme, et la métaprogrammation).

Bonne chance
seckychrystopher Messages postés 3 Date d'inscription lundi 18 février 2013 Statut Membre Dernière intervention 23 février 2017
23 févr. 2017 à 10:45
EN faite je ne commence pas. Je faisais quelques codes il y a 5ans. Mais , je me suis désintéressé. Et, là je compte me relancer.
Mais merci quand mm
0
mamiemando Messages postés 33207 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 24 juillet 2024 7 765
24 févr. 2017 à 09:57
As-tu essayé avec code::blocks ? (cf lien)
Là j'ai l'impression (mais le message d'erreur est un peu succinct) que c'est le compilateur qui n'est pas trouvé.
0
TACCINI17 Messages postés 2 Date d'inscription jeudi 23 février 2017 Statut Membre Dernière intervention 25 février 2017 > mamiemando Messages postés 33207 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 24 juillet 2024
25 févr. 2017 à 09:51
Actuellement j'essaye avec code::block, c'est pareil.

-------------- Build: Debug in TestCodeB1 (compiler: GNU GCC Compiler)---------------

g++.exe -o bin\Debug\TestCodeB1.exe obj\Debug\main.o
Process terminated with status 255 (0 minute(s), 7 second(s))
0 error(s), 0 warning(s) (0 minute(s), 7 second(s))


-------------- Run: Debug in TestCodeB1 (compiler: GNU GCC Compiler)---------------

Checking for existence: C:\Users\USER\Programmation\TestCodeB1\bin\Debug\TestCodeB1.exe
0
TACCINI17 Messages postés 2 Date d'inscription jeudi 23 février 2017 Statut Membre Dernière intervention 25 février 2017 > TACCINI17 Messages postés 2 Date d'inscription jeudi 23 février 2017 Statut Membre Dernière intervention 25 février 2017
25 févr. 2017 à 11:10
Merci pour vos orientations.
J'ai installé mingw-get-setup.exe
ça fonctionne très bien.
0
mamiemando Messages postés 33207 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 24 juillet 2024 7 765
27 févr. 2017 à 10:25
Merci pour ton retour :-)

Pour ton erreur "status 255" il semblerait qu'il y ait plusieurs explications possible :

- le terminal appelé par code::blocks n'était pas installé.
https://community.linuxmint.com/tutorial/view/1597

- la version utilisée est bugguée :
https://stackoverflow.com/questions/13756389/error-255-when-try-to-create-exe-using-dev-c



Bonne chance