Conditions comprise entre 2 valeurs [Résolu/Fermé]

Signaler
Messages postés
1
Date d'inscription
jeudi 30 octobre 2014
Statut
Membre
Dernière intervention
30 octobre 2014
-
 Bourlamaque -
Bonjour,
J'aurais besoin d'une formule pour la situation suivante : si, dans ma cellule (B3), le total des heures travaillées est compris entre 8 et 13,75, je veux afficher "forfait" et si le total est compris entre 14 et 16,75, je veux afficher "long".

Pour l'instant, je suis obligée de faire 2 colonnes, mais je voudrais tout retrouver dans la même cellule.

Quelqu'un peut m'aider ?

7 réponses

Ça marche, merci ! Pas de souci pour le vide entre 13,75 et 14, ce sont des heures alors selon mes besoins, l'employé est arrondi au quart d'heure.

Par contre, où est-ce que j'insère ma condition de =SI(B3<=4;4) Parce que si l'employé travaille moins de 4 heures, il est tout de même payé 4 heures...

Quand j'essaie de l'insérer, ça me donne un message d'erreur.

Et non, je n'ajouterai pas d'autres conditions !!!! :)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
17242
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 octobre 2020
4 284
Re,

il suffit de placer la condition dans la formule comme les autres en respectant on ordre croissant ou décroissant

=SI(ET(B3>=14;B3<=16,75);"long";SI(ET(B3>=8;B3<=13,75);"Forfait";SI(ET(B3>0;B3<=4);4;"total de la cellule")))
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Merveilleux, ça marche !!!!! Merci infiniment !!
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
25367
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020
5 521
Bonjour

=SI(ET(A1>=8;A1<=13,75);"Forfait";SI(A1>=14;A1<=16,75);"long";""))

crdlmnt

Ça ne fonctionne pas...

En fait, j'ai 3 conditions
plus petit que 4 = 4
entre 8 et 13,75 = forfait; sinon total de la cellule
entre 14 et 16,75 = long; sinon total de la cellule
Messages postés
17242
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 octobre 2020
4 284
Bonjour,

essaye comme cela

=SI(ET(B3>=8;B3<=13,75);"Forfait";SI(ET(B3>=14;B3<=16,75);"long";"total de la cellule"))

mais il y a un vide que faire entre 13,75 et 14 et d'après ton dernier post entre 4 et 8 que faire, ce n'est pas très clair

il ne serait pas question de >=14 long et >= 8 forfait et inférieur à 8 rien dans ce cas

=SI(B3>13,75;"long";SI(B3>=8;"forfait";"total de la cellule"))

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
52430
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020
14 279
... et tu nous promets qu'une quatrième condition ne viendra pas s'ajouter ?