Passage en HTTPS = Bug [Résolu/Fermé]

Signaler
Messages postés
583
Date d'inscription
samedi 27 janvier 2007
Statut
Membre
Dernière intervention
30 décembre 2019
-
 sevs -
Bonjour,

J'ai un mutualisé chez OVH où j'héberge un site privé en PHP.
J'ai forcé le SSL sur mon sous-domaine via un .htaccess :

RewriteEngine On
RewriteCond %{HTTP_HOST} ^example\.com [NC]
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://www.example.com/$1 [R,L]

Le passage en HTTPS fonctionne bien MAIS ça fou la merde...

L'autocompletion JQuery ne fonctionne plus, les Font Awesome non plus, de même que pour certaines images.

La plupart de mes références pointent pourtant vers du contenu local.

Voici un extrait de mes liens :

    <!-- Jquery CSS pour AutoComplete -->
    <link rel="stylesheet" href="http://ajax.googleapis.com/ajax/libs/jqueryui/1.10.1/themes/base/minified/jquery-ui.min.css" type="text/css" /> 

    <!-- Bootstrap Core CSS -->
    <link href="../bower_components/bootstrap/dist/css/bootstrap.min.css" rel="stylesheet">

    <!-- MetisMenu CSS -->
    <link href="../bower_components/metisMenu/dist/metisMenu.min.css" rel="stylesheet">

    <!-- Custom CSS -->
    <link href="../dist/css/sb-admin-2.css" rel="stylesheet">

    <!-- Custom Fonts -->
    <link href="../bower_components/font-awesome/css/font-awesome.min.css" rel="stylesheet" type="text/css">

    <!-- Custom CSS -->
    <link href="../dist/css/perso.css" rel="stylesheet">

    <!-- Bootstrap Core JavaScript -->
    <script src="../bower_components/bootstrap/dist/js/bootstrap.min.js"></script>

    <!-- Metis Menu Plugin JavaScript -->
    <script src="../bower_components/metisMenu/dist/metisMenu.min.js"></script>

    <!-- Custom Theme JavaScript -->
    <script src="../dist/js/sb-admin-2.js"></script>


Avez-vous une idée du problème ?

Par avance, merci.

Rom

1 réponse

HTTPS --> Désactive les scripts :D
Conclusion les pages où tu as des scripts doivent être en http
J'avais le même soucis sur certaines pages donc j'ai viré le https auto et j'ai mis un lien https://nomdusite/page
et ainsi de suite sauf sur les dites pages
Messages postés
583
Date d'inscription
samedi 27 janvier 2007
Statut
Membre
Dernière intervention
30 décembre 2019
33
Oh ?
Bah mince...
Tu peux bien avoir des pages web en https qui comportent des scripts quand même ?