Faire la somme de chiffres malgrés des lettres [Résolu/Fermé]

Signaler
Messages postés
1859
Date d'inscription
samedi 25 février 2012
Statut
Membre
Dernière intervention
28 avril 2021
-
Messages postés
24042
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
3 mai 2021
-
Bonjour,
Je suis novice et j'ai un soucis avec une formule.
J'ai créé un tableau pour une commande de pommes et quelques fois, je dois mettre un V (verte) ou J (jaune) avec le chiffre.
Du coups dans mon total, la formule est fausse quand il y a la lettre.
Dans l'exemple que je vais vous joindre, il y a 2 V et 1 J dans la colonne GOLDEN.
Le résultat est de 4 alors que c'est 6 pour le sac de 5 kg et de 1 alors que c'est 2 pour le sac de 10 kg.
Pouvez vous m'aider s'il vous plait ?
Merci d'avance.

https://www.cjoint.com/c/FJfixUjSFWs





« Je peux accepter l'échec, tout le monde échoue dans quelque chose. Mais je ne peux pas accepter de ne pas essayer »

8 réponses

Messages postés
598
Date d'inscription
mercredi 5 octobre 2016
Statut
Membre
Dernière intervention
7 mars 2021
50
peut etre créer une colonne supplémentaire pour inscrire la couleur?
Messages postés
1859
Date d'inscription
samedi 25 février 2012
Statut
Membre
Dernière intervention
28 avril 2021
330
Bonjour et merci.
C'est une solution mais à mon avis, il y a sûrement une formule.
Cordialement.
Messages postés
598
Date d'inscription
mercredi 5 octobre 2016
Statut
Membre
Dernière intervention
7 mars 2021
50
essayez ça :
=SOMME(B1:B8)+NB.SI(B1:B8;"v")+NB.SI(B1:B8;"j")
Messages postés
25998
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
2 mai 2021
5 906
Bonjour

essayez cette formule en B21
attention Formule matricielle à entrer comme suit:
touche enter en maintenant enfoncées les touches ctrfl et shift enfoncées
elle s'affiche entre accolades dans la barre de formu
le

=SOMMEPROD((SI(B4:B20<>"";GAUCHE(B4:B20;1)*1)*1))

note: cette option suppose que le nombre de sac par cellule ne dépasse pas 9 (un seul chiffre donc)
si ce n'est pas le cas, écrire:
=SOMMEPROD((SI(B4:B20<>"";GAUCHE(B4:B20;2)*1)*1))
qui ira jusqu'à 99
mais il faudra alors impérativement placer un blanc entre la valeur et la lettre

crdlmnt
La qualité de la réponse dépend surtout de la clarté de la question, merci!
Messages postés
1978
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
28 septembre 2020
840
Bonjour à tous,

Il y a sans doute plus simple, mais voici une formule matricielle qui fonctionne :
=SOMMEPROD(SIERREUR(--SUPPRESPACE(SUBSTITUE(SUBSTITUE(B$4:B$20;"J";"");"V";""));0))

à valider par CTRL+MAJ+ENTER

cordialement
Messages postés
1859
Date d'inscription
samedi 25 février 2012
Statut
Membre
Dernière intervention
28 avril 2021
330
Bonjour et merci pour l'aide.
J'ai utilisé votre formule et ça fonctionne.
Finalement, j'aimerai remplacer V par Vertes et J par Jaunes, le fournisseur préfère.
Est ce possible ?
Merci.
Messages postés
25998
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
2 mai 2021
5 906 >
Messages postés
1859
Date d'inscription
samedi 25 février 2012
Statut
Membre
Dernière intervention
28 avril 2021

Bonjour
en attendant JvDo (salut ami) si vous utilisez sa proposition:
il suiffit d'écrire entre les guillemets les textes que vous utilisez à la place de V et J
Si vous utilisez ma proposition jusqu' à 99 , ça fonctionne sans modification
crdlmnt
Messages postés
1859
Date d'inscription
samedi 25 février 2012
Statut
Membre
Dernière intervention
28 avril 2021
330 >
Messages postés
25998
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
2 mai 2021

Bonjour et merci.
J'avais essayé mais j'ai oublié de valider par ctrl+maj+enter.
Maintenant, ça fonctionne.
Encore merci et bonne journée.
Messages postés
5551
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
28 avril 2021
601
Bonjour mj1974

Votre fichier modifié

http://www.cjoint.com/c/FJfiTgwLxrx
Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020
65
Bonjour ,

2 solutions ,

regarde le fichier ci joint
https://www.cjoint.com/c/FJfiWzmtydH

Les "0" sont obligatoires pour la deuxième solution .

Cordialement,

Nos seules limites sont celles que nous nous imposons nous-même.
La politesse et un merci ne tuent pas. Il existe un bouton pour "Résolu" pour confirmer que     votre problème n'en est plus un. Fahora
Messages postés
1859
Date d'inscription
samedi 25 février 2012
Statut
Membre
Dernière intervention
28 avril 2021
330
Bonjour.
Tout d'abord, merci à tous.
C'est résolu.
Bonne journée.



« Je peux accepter l'échec, tout le monde échoue dans quelque chose. Mais je ne peux pas accepter de ne pas essayer »
Messages postés
24042
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
3 mai 2021
6 754
Bonjour,

Tu ferais mieux de considérer Golden Verte et Golden Jaune comme 2 produits différents, ce qu'ils sont d'ailleurs.
Aucun intérêt à procéder comme tu veux.
eric